Third party Chrome doesn't remember 'stay logged in' on xenforo.com

Grover

Well-known member
#1
See: http://xenforo.com/community/thread...-chrome-stay-logged-in-doesnt-function.12496/

I am not sure if it's a bug, but it's curious that only xenforo.com seems to be affected by the issue I am experiencing. I cleaned my Chrome cache in every way possible, multiple times. Every site I need to log on to remembers my login details and logs me in automatically every time. Only on xenforo.com it doens't work anymore (I have this issue since a couple of days).

In Firefox there is no problem however.
 

Brogan

XenForo moderator
Staff member
#2
I use Chrome and have done for the last 6 months+ on here.

It works fine for me.

The same applies to my own XenForo powered site.
 

Grover

Well-known member
#4
Strangely enough it indeed only seems to appear for me on xenforo.com ... everything else (like Google Calendar and several other sites where I need to log in) works fine.
 

Brogan

XenForo moderator
Staff member
#5
I posted this on the other thread but if you sign out and clear all cache, including cookies, passwords, etc. then that should fix it.
 

Grover

Well-known member
#10
Might be obvious but have you checked your exclusions in the Chrome options? You may have XF excluded.
Yeah, but no... I haven't changed a thing on my side. I just started noticing these problems on XF.com with Chrome a few days ago. I searched on Google and found out that lots of people have problems with cookies/cache of Chrome, but in my case it's strange that only XF.com seems to be affected by this (for me).
 

James

Well-known member
#11
Grover, log out and back in again (ensuring you tick the stay logged in box), then do either:
Right click -> Inspect Element -> Resources -> Cookies -> xenforo.com
Spanner icon -> Options -> Under the Hood -> Content settings... -> Cookies -> Show cookies and other site data... -> Search: xenforo

Once doing one of the above methods, see if the cookie name xf_user is visible once logged in.
 

Grover

Well-known member
#12
Grover, log out and back in again (ensuring you tick the stay logged in box), then do either:
Right click -> Inspect Element -> Resources -> Cookies -> xenforo.com
Spanner icon -> Options -> Under the Hood -> Content settings... -> Cookies -> Show cookies and other site data... -> Search: xenforo

Once doing one of the above methods, see if the cookie name xf_user is visible once logged in.
Hello James,

When perform the 1st action I see this:

__utmz
123000322.1303302129.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
.xenforo.com
/
Thu, 20 Oct 2011 00:22:09 GMT
76
xf_session
066c8fcce7ba4a41aefd96046f528766
xenforo.com
/
Session
42

__utma
123000322.1567630232.1303302129.1303333497.1303337576.4
.xenforo.com
/
Fri, 19 Apr 2013 22:41:16 GMT
61
__utmc
123000322
.xenforo.com
/
Session
15
__utmb
123000322.22.10.1303337576
.xenforo.com
/
Wed, 20 Apr 2011 23:11:16 GMT
32
_twitter_sess
BAh7CDoPY3JlYXRlZF9hdGwrCBZtGkUuASIKZmxhc2hJQzonQWN0aW9uQ29u%250AdHJvbGxlcjo6Rmxhc2g6OkZsYXNoSGFzaHsABjoKQHVzZWR7ADoHaWQiJWUz%250ANzZjMTA3Y2Q2OTU0NDgwM2I4NzZjOWIzZmM1OTU5--f3460d0073f09bf5d3f3c6fca12d4243cbd101bc
.twitter.com
/
Session
225
(Aaarghhh... how I long for http://xenforo.com/community/threads/table-bbcode-functionality.11123/ !)

Anyway, I am still having this problem, only on XenForo.com
 

Brogan

XenForo moderator
Staff member
#13
There is no XenForo cookie being set it would seem, hence why you are having the problem.

Have you perhaps blocked cookies for this site inadvertently?
 

Grover

Well-known member
#14
There is no XenForo cookie being set it would seem, hence why you are having the problem.

Have you perhaps blocked cookies for this site inadvertently?
Not that I am aware of Brogan, I didn't change a single thing in Chrome. Not sure what I am overlooking (since it's apparently a thing on my side).
 

Brogan

XenForo moderator
Staff member
#15
Don't worry, it's just a glitch in the matrix, we'll get it sorted ;)

Check your cookie settings here - they should be the same as mine.
cookies.PNG
 

Grover

Well-known member
#16
Don't worry, it's just a glitch in the matrix, we'll get it sorted ;)


Thank you, Mr. Tank
(or your prefer Morpheus?),

Well... I already checked those option screens a zillion (or should I say: a 'Zionly') times and all my option are set correctly. That's why it's rather frustrating this problem keeps occurring, because everything seems to be set correctly in Chrome (I didn't change a thing to begin with... I started have this problem on XF.com spontaneously a few days ago)
 
F

Floris

Guest
#17
Can't reproduce. I have used it since Chrome 10 now 24/7 and I stay logged in on all the domains on the same site.

make sure your apc has a unique cache and your cookie prefix is set in config.php
 
F

Floris

Guest
#19
Oh, ok. xfcom
NO problems here either.

I am on osx snow leopard 10.6.7 , 64bit, and using chrome and safari to browse here. No firewall or security software installed that could block cookies or alike.
 

craigiri

Well-known member
#20
I am a long time mac user and have no doubts that Chrome acts a little funny on some sites - I think mostly with JS.
I use FF, Chrome and sometime Safari to test...but Chrome and FF on a daily basis. I will often find parts of my site or other site...small things like buttons that I push and nothing happens...in Chrome, but then opening FF and using the same button produces results.

This is probably one of those things which is tough to troubleshoot. I just don't.

Yesterday I was helping a friend who was finding that a big financial portal was not working right on his new mac. I went through Safari, FF and then Chrome, and still was only partially solving the problem (Chrome, in this case, was working the best).
As a last ditch effort I downloaded Opera...and that worked the best of all four! Hey, when you can't work with it, you work around it.
 
Top