• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Changing user groups causing staff having to reset password

#1
So all my staff's primary user group was their respective staff user group. I switched all of them to the member user group and put their secondary as their respective staff user group.

All my staff were logged out and had to reset their password. Is this normal? I don't think it is.
 

Mike

XenForo developer
Staff member
#2
This isn't normal and I can't see any reason for this to happen (nor have I ever seen a report of this before). There's no code that would cause this. I suppose an add-on could be involved?
 
#3
This isn't normal and I can't see any reason for this to happen (nor have I ever seen a report of this before). There's no code that would cause this. I suppose an add-on could be involved?
Yeah that's what I was thinking.

Here are all the add-ons I have installed.

Screenshot_2015-12-05-10-58-10.png
Screenshot_2015-12-05-11-06-01.png
 
Last edited:

Mike

XenForo developer
Staff member
#4
The first troubleshooting step would be to reproduce the issue with add-ons disabled. If it doesn't happen, you'd generally need to re-enable them one by one to identify the cause.

Thinking more though, I'm guessing that your browser is autofilling the password field on the user edit page which is changing the password of anyone you edit. (The field should be blank to not change the password.)
 
#5
The first troubleshooting step would be to reproduce the issue with add-ons disabled. If it doesn't happen, you'd generally need to re-enable them one by one to identify the cause.

Thinking more though, I'm guessing that your browser is autofilling the password field on the user edit page which is changing the password of anyone you edit. (The field should be blank to not change the password.)
Oh! That was what was happening! I didn't see that. Thanks Mike!