• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Changed Host, Email Confirmation not working anymore

BamBam

Active member
#1
Hi,

I am using XF 1.2.1, with PHP 5.3. I have changed the Hoster today, and now my Email Confirmation is not working anymore. The Email Confirmation is skipped, and it comes directly to the Admin Approval (i have it enabled, because Email Confirmation is not working anymore):

hmm2.png

Thanks for registering. Your registration must now be approved by an administrator. You will receive an email when a decision has been taken.
hmm.png

What could that be, a Server Issue? Thx. :(:(:(:(:(

// Nothing in the Logs
 

Brogan

XenForo moderator
Staff member
#2
What do you mean by "not working"?

Are the emails being sent and received?
Is it the confirmation link which is incorrect?
 

BamBam

Active member
#3
There is no Email, because the Confirmation is skipped, and i comes to the Manual Approval. Like in the Screenshots, there is no Text "You have to click on the Email...bla bla", only "Thanks for registering. Your registration must now be approved by an administrator. You will receive an email when a decision has been taken".

Normal Emails (Watched Threads, PM...) are working.
 

Mike

XenForo developer
Staff member
#4
If you're getting the manual approval in this scenario, it's likely because some spam flag is being triggered (which sends it to manual approval). If you're manually approving all users already, you can disable any of the spam levels that trigger manual approval (but you can keep outright rejections).