1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Change of username

Discussion in 'Media Gallery Resolved Bugs' started by teletubbi, Jul 25, 2016.

  1. teletubbi

    teletubbi Active Member

    Today I saw something where I need a explanation.

    We had a user who want to change his name.
    Not a big deal at all.

    But if I look in gallery the albums there are still listed under his old name.
    How does it comes?

    He can access it with his new name. Also permission are in order. So the albums reflect the new name with all permission.

    Just say on top albums of user A where I should be albums of user B
  2. Amaury

    Amaury Well-Known Member

    Might be similar to conversations where you need to explicitly rebuild the corresponding caches.
  3. teletubbi

    teletubbi Active Member

    The change of this username was done several months ago.
    Should this not be done automatically in this time?

    I saw it only today because I was checking something else in gallery.
  4. teletubbi

    teletubbi Active Member

    Rebuilding the cache of the user information don't change this.
    Just tried.
  5. Chris D

    Chris D XenForo Developer Staff Member

    There should be code to handle this already if it doesn't work as expected then it may be a bug.
    Amaury likes this.
  6. Chris D

    Chris D XenForo Developer Staff Member

    I just gave this a test and double checked the code was correct (there's not a lot of scope for it to go wrong) and everything looks and works how I would expect it to. All of the albums and media inside the albums, the owner is listed as the new name.

    The only thing I can think of, really, is whether the process to change the content was somehow disrupted. It's potentially an operation that can take some time, but I think it would be clear if it had failed.
  7. teletubbi

    teletubbi Active Member

    As I wrote this change was about 2 or 3 month ago.

    But I also explain it wrong.

    On the member card I choose album of user.
    Than I am in the gallery where it shows me his albums. Here the name has changed. So everything like it should. But if I go inside his album it shows me the old name on top above the pictures.

    It is nothing what disturb really because everything else is working like expected.
  8. Chris D

    Chris D XenForo Developer Staff Member

    The username doesn't actually appear anywhere "above the pictures".

    This is a view of the contents of an album:


    The only place the username appears is in the sidebar.

    In my testing, this is correct.

    However, are you talking about the title of the album? In this case the album title is "Test Album".

    If his album actually contains his old name in the title, this wouldn't be updated.
  9. teletubbi

    teletubbi Active Member

    You are right it was the title of the album.
    This Titel was generated by the VB software for new users and imported when we did the switch.

    I changed i now by hand.
    Chris D likes this.

Share This Page