1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

change from [BLOB - 12B] to [BLOB - 64B]

Discussion in 'XenForo Development Discussions' started by netkingZ, Oct 7, 2013.

  1. netkingZ

    netkingZ Active Member

    Hello , i need change the recipients of xf_conversation_master from [BLOB - 12B] to [BLOB - 64B], how can I do?

    I tried to pass the data through DataWriter and ControllerPublic but the data does not change, however I need that through the ControllerPublic and DataWriter the data is changed from the current [BLOB - 12B] to [BLOB - 64B].

    In Add-on that I'm creating I need to send a conversation but being the recipients of xf_conversation_master set to [BLOB - 12B] is generated so an error in the JS console but if you were able to set the recipients to [BLOB - 64B] as for normal conversations that you make with xenForo I might have solved the problem.

    Thanks you
    Last edited: Oct 7, 2013
  2. Jeremy

    Jeremy Well-Known Member

    Use an ALTER statement and then make sure that the data writer is updated to include the new declaration.
  3. netkingZ

    netkingZ Active Member

    How is the correct wording to make the change?
    I've never used ALTER.

    I do not want to change it to another type, such as BLOB 12B to VARCHAR , I want you to change from [BLOB - 12B] to [BLOB - 64B]
  4. netkingZ

    netkingZ Active Member

    I tried entering:


    the error that continues to pose is this:

    the console error is this:

    The data are entered into the database and pass the only voice that does not come back is precisely that of recipients that is set with [BLOB - 12B].
    So I guess the error in the Js and that I posted above prorpio resulting from that.
  5. netkingZ

    netkingZ Active Member

    can anyone help me?
  6. netkingZ

    netkingZ Active Member

  7. Lawrence

    Lawrence Well-Known Member

    You can't. that 12B is the amount of data (in Bytes) that is currently contained in that blob. It changes automatically as there is more or less data stored in it. I'm not sure what you are trying to do, why 64B is important to you. Try increasing the number of conversation recipients setting in the registered user group permissions page, maybe? Remember BLOBS need serialized data, so the data needs to be unserialized for the foreach to work.
  8. netkingZ

    netkingZ Active Member

    and the error that comes out not you tell me anything?

    May depend on the amount of bytes or not?


    I reached 64bytes but the error persists because the data is serialized, how can I solve?
    What I'm trying to do is to send a conversation outside of the usual conversation system xenForo and directly upload the data to the database.

    how can I unserialized?
    Last edited: Oct 8, 2013
  9. netkingZ

    netkingZ Active Member

    Solved!! ... ;)

Share This Page