1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Partial Fix Censoring is not working properly with foreign language (russian)

Discussion in 'Resolved Bug Reports' started by Romchik®, Jun 8, 2011.

  1. Romchik®

    Romchik® Well-Known Member

    In ACP:

    word (Match exact word ) -> ****
    слово (Match exact word ) -> *****

    In message:

    word -> ****
    слово -> *****
    woRd -> *****
    слоВо -> слоВо

    Half solution (thanks Yoskaldyr):
    in /library/XenForo/Helper/String.php
    Code:
                        $search = '#(?<=\W|^)(' . preg_quote($word, '#') . ')(?=\W|$)#i';
    replace with
    Code:
                        $search = '#(?<=\W|^)(' . preg_quote($word, '#') . ')(?=\W|$)#iu';
    But this work only with "Match exact word " option.
     
    CyberAP, Vincent and Yoskaldyr like this.
  2. Kier

    Kier XenForo Developer Staff Member

    The partial fix is now in 1.0.3
     

Share This Page