1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Category choices pulldown is blank

Discussion in 'Resolved Bug Reports' started by cdub, Apr 1, 2013.

  1. cdub

    cdub Well-Known Member

    I'm playing around with the resources in the demo (very cool feature btw) and when I go to add a resource the pull down list is blank.

    I have 4 possible category choices and when I mouse over it you can see the items. (shown in second picture)

    I'm running Chrome (Chrome OS to be exact on this computer but it's the same as all versions of Chrome)

    Screenshot 2013-03-31 at 4.46.59 PM.png Screenshot 2013-03-31 at 4.44.01 PM.png
     
  2. Mike

    Mike XenForo Developer Staff Member

    That looks like a Chrome OS bug to me as it's fine here. Does the same thing happen if you try to move a thread? (With the forum chooser.)

    Unfortunately, I don't have an easy way to test Chrome OS.
     
  3. cdub

    cdub Well-Known Member

    Strange... I just checked on Safari and Chome on a Mac and it doesn't happen there.

    Just on Chrome OS 25 stable. Which is odd because Chrome OS should be identical to Chrome eslewhere but it isn't.
     
  4. Despair

    Despair Active Member

    I've had this issue for from a long time ago when using Chrome/Chromium on some Linux flavours. I think the issue is with any select options within a form overlay and not just the resource manager. I've simply been using this css to fix it:
    Code:
    /* chrome */
    .xenOverlay .formOverlay select option
    {
        background-color: {xen:property primaryDarker};
    }
    I never bothered testing on other OS's though, so probably need a quick look to see that things are looking right everywhere else.
     
  5. cdub

    cdub Well-Known Member

    Cool... where do I need to put this CSS? Into the main file? Where can I edit that? (i haven't gotten to messing with that section yet)
     
  6. cdub

    cdub Well-Known Member

    And since Chrome OS is basically the Chrome browser on a stripped down form of Linux that makes sense.
     
  7. Despair

    Despair Active Member

    The easiest would probably be your EXTRA.css file within your style. Or if you only wanted it to load for the overlays, you could add it in xenforo_overlay.css (you'd have to redo the edit each update without TMS), although it's so small I don't think there is much harm in extra.
     
  8. cdub

    cdub Well-Known Member

    Awesome that worked. Thanks!
     
  9. Mike

    Mike XenForo Developer Staff Member

    I've just applied a similar fix. Thanks.
     
  10. Despair

    Despair Active Member

    Forgot to mention that if you have this issue, it's also difficult to see the drop down arrow. You could apply your own background image underneath the arrow, but not sure if it's worth it.
     
  11. Hardcore

    Hardcore Active Member

    This occurs using Chrome on my Samsung Chromebook, but no other versions of Chrome that I use.

    I'll try this fix and report back.
     
  12. Despair

    Despair Active Member

    I believe this is already fixed on XF. Easiest way to test is to go to resources and try adding a resource, you should see the overlay with a select menu.
     
  13. Jeremy

    Jeremy XenForo Moderator Staff Member

    Its been fixed for the next released version, not v1.1.4.
     
  14. Despair

    Despair Active Member

    I meant that it's already rolled out on xenforo.com so that he could test it. ;) Reason why I said to visit resources to test it since you wouldn't have access to most other form overlays unless you're a mod, I already tested it the other day and it's working now.
     
    Jeremy likes this.
  15. Hardcore

    Hardcore Active Member

    Also, I meant to add that this also occurs during moderation when moving a thread and selecting a new forum destination; I'm assuming it's the same exact issue. (Need to remember to have a coffee before posting.)
     
  16. Jeremy

    Jeremy XenForo Moderator Staff Member

    :unsure: I read in XF not on. I shouldn't read XF while at work when my brain is fighting with client sites and working on a problem. I'll go hide in a corner.
     
  17. Despair

    Despair Active Member

    Yea, mentioned that above, probably any select menus within an overlay. The CSS targets all the form overlays (.xenOverlay .formOverlay .textCtrl:focus option and .xenOverlay .formOverlay .textCtrl option) and not just the resource manager, so it should fix them all.
    No worries, easy mistake to make, I could have been more specific too. :)
     

Share This Page