1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't view a custom html/php page from my xenforo's server.

Discussion in 'XenForo Development Discussions' started by EQnoble, Dec 16, 2010.

  1. EQnoble

    EQnoble Well-Known Member

    I tried to make a custom little script to do a small task inside of xenforo...but I cannot view it in my browser. ( /public_html/somedoc.html) it always gives me xen page with page not found or permissions error no matter what I do. What can I do here?
  2. Shadab

    Shadab Well-Known Member

    Can you paste the contents of your custom page?
    Or attach it as a zip if it's too large.
  3. EQnoble

    EQnoble Well-Known Member

    Thank you for your reply,
    I actually found a workaround and can continue expanding on my feature.

    But as far as this problem went...
    I made a html doc that had nothing to do with xenforo...when placed in my xenforo domain's webroot the page is not visable and a xenforo security warning comes up... the contents shouldn't matter in this regard I think.

    Now I went and changed a bunch of randomness and now can view random docs, ( call it mydoc.php ) so my logical question would be, what could I have possibly changed to do that, or what controls viewing permissions of pages not part of xenforo but residing in it's domain webroot.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    I have many html and php pages in my domain root with XenForo in a sub-directory and I can view all of them just fine.

    Can you post a screenshot of the error which was displayed?
    I'm confused as to why it would be a XenForo related error if it is outside the directory.
  5. EQnoble

    EQnoble Well-Known Member

    I have xenforo in the root and want to keep it there , I just wanted to be able to add pages myself in that directory.

    I messed with so much on my board since this happened and don't see the error anymore but whatever I did also broke some functionality of the board so I am going to reinstall the whole board and redo all of my steps I took to get what I want accomplished. If the error comes up again I will post back here as right now I don't have screen shots or pasted text of the errors. I may have solved my own problem but don't hold me to that... I'm finishing my coffee and reinstalling XF right now.

  6. Brogan

    Brogan XenForo Moderator Staff Member

    I misunderstood your previous post, I thought you had XenForo installed in a sub-directory.

    Even so, you should still be able to have other pages in the root as long as you don't name them the same as the existing XenForo files; index.php, admin.php, etc.

    Post back with how the reinstall goes.
  7. EQnoble

    EQnoble Well-Known Member

    Install done,

    Installing the same addons in the same order
    then my template edits
    then my custom pages

    <con't>addon installations: Done</con't>
    addon functionality fail -- /me is lost
  8. EQnoble

    EQnoble Well-Known Member

    Yeah back to that same issue... I made a custom php page for my uploaders and it will not display on sites where xenforo is in the site root , well specifically the php files won't, the html show up fine.

    Is there something I must do in order to make the page display?
  9. Kier

    Kier XenForo Developer Staff Member

    The XenForo rewrite rules operate by intercepting any requests for non-existent files and directories. If your URL to the custom script is not 100% correct, XenForo will receive the request instead. Are you sure you don't have an issue like an uppercase/lowercase filename discrepancy?
  10. EQnoble

    EQnoble Well-Known Member

    nah it's exact...im 100% sure.. i in fact have my desired pages working on my site...which has xf installed under /forums, the issue came back about when I made this little snippet to upload those sig images you love so much and a user here had the issue of the page displaying...the html page has the form which displays just fine...but when it references the .php document that handles the input form , no dice... just ' The requested page could not be found."

    the thing is when xf is installed to a sub directory it doesn't have that problem no matter if the files are in www root or in the sub directory xf is installed in.... same exact pages will not work when xf is installed to the site root. It is perplexing to me...thoughts?
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Presumably you're changing the relative path(s) which reference the php file when moving the install to the root?
  12. EQnoble

    EQnoble Well-Known Member

    well since they both go in the same directory , the way i'm referencing the php from the html is "xxsU.php" which works on my site with a sub-domain xf install ( your suggestion of installing to a sub directory a while back prompted me to try and it fixed all my issues related ) Making the uploader for the public is what made me remember this issue from before after being told of the page error on the users site...i checked myself and the html page shows up as a standalone page but submitting the form, it cant find it.
  13. EQnoble

    EQnoble Well-Known Member

    RC1 has solved this, tested it on multiple install configurations with no issues. AWESOME ..THANKS


Share This Page