1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't upload an Avatar

Discussion in 'Troubleshooting and Problems' started by PVO_Dave, May 19, 2011.

  1. PVO_Dave

    PVO_Dave Active Member

    I get the following:

    The temporary file for the upload cannot be found.
        XenForo_Upload->__construct() in XenForo/Upload.php at line 350
        XenForo_Upload::getUploadedFiles() in XenForo/Upload.php at line 367
        XenForo_Upload::getUploadedFile() in XenForo/ControllerPublic/Account.php at line 470
        XenForo_ControllerPublic_Account->actionAvatarUpload() in XenForo/FrontController.php at line 310
        XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
        XenForo_FrontController->run() in C:/Inetpub/wwwroot/testforum/index.php at line 13
    The server runs IIS (boooooo) and I've granted full permissions to the data and internal_data (and sub folders) but still get the error, the only other threads I've found on this pointed to the permissions, but that doesn't seem to have solved it for me.

    What can I check next?
  2. PVO_Dave

    PVO_Dave Active Member


    Apologies, didn't see the Error Log in the CP! - It was down to the fact that the system couldn't write to the Windows Temp directory!

    Lawrence likes this.
  3. Lawrence

    Lawrence Well-Known Member

    Thanks for posting the solution, Dave, I'm sure others in the future will run into the same problem.
  4. PVO_Dave

    PVO_Dave Active Member

    No worries Lawrence, just for further info then: to resolve, you need to give the IUSR_SERVERNAME account write access to the windows temp directory :)

    Lawrence likes this.

Share This Page