1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't upgrade from Beta 6 to RC2

Discussion in 'Installation, Upgrade, and Import Support' started by brendanc, Feb 15, 2011.

  1. brendanc

    brendanc Active Member

    I downloaded the RC2 upgrade package, replaced all the files, and when I go to www.domain.com/install, it says:

    No Upgrade Available

    You are already running the current version (1.0.0 Beta 6). To do a fresh install, click here.

    What gives?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It sounds as if you haven't uploaded all of the files or you uploaded them to the wrong directory.
     
  3. brendanc

    brendanc Active Member

    No, they're in the right directory. But you got me thinking, is there a file that tells the installation it's not upgraded? Essentially what I did, to save time, was move my .htaccess, custom style folder, and library/config.php file out, backed up all the other stuff, and copied the RC2 files from another folder, and then replaced all my unique stuff.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    That really isn't the correct way to do an upgrade.

    All you need to do is upload the new package, overwriting all files.

    Browse to the install path and run the upgrade.

    Afterwards revert all outdated templates and phrases and reapply any edits you have made.

    Your custom styles folder (assuming it's not the default), .htacess file and config.php won't be overwritten if you use the upgrade package so there really is no need to do what you've done.
     
  5. brendanc

    brendanc Active Member

    My FTP program (Transmit 4 on mac) is a pain with XF upgrades. It really takes forever to upgrade XF.

    If I tell it to replace my styles folder, it will literally replace it (deleting my custom style folder). Same thing with the library folder and config.php. It will delete config.php in the process of "replacing" the library folder.

    I still don't understand why the installation identifies itself as Beta 6 with the RC2 files, though (for upgrade purposes).

    Furthermore, I haven't had this problem before, so I'm not sure what's going on.
     
  6. steven s

    steven s Well-Known Member

    You should keep your custom stuff in it's own directory.
    styles/default/yourstuff

    I've been using Fetch since before the flood.
     
  7. brendanc

    brendanc Active Member

    I do...

    I keep it in styles/<my dir>
     
  8. steven s

    steven s Well-Known Member

    Guess it's a FTP setting then.
     
  9. Floris

    Floris Guest

    it is

    transmit is very nice for xenforo, and very flexible.

    just make sure if you have the settings set for the queue as well, not just the normal single file transfer.

    check preferences:
    [​IMG]

    go to the queue by the small icon bottom left, then set it under conflict

    [​IMG]
     
  10. brendanc

    brendanc Active Member

    Ah, ok. I'm going to restore the backup and do-over.
     
  11. brendanc

    brendanc Active Member

    Worked this time.

    Also, I found out why it didn't work...

    You see, I've been changing servers the past few days... and I thought I had pointed my forum's domain over to the new server... and was operating on that assumption when I went to the URL. Since I hadn't made any other changes, I figured I was good. Didn't ping the domain to check the IP it was on (duhrrrrrr). Once I actually pointed the domain at the new server, it was fine (and, for the record, what I did would have worked ;P)

    So, thank you guys for the help (and the very useful Transmit tips).
     

Share This Page