• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Can't upgrade any add ons


Active member
I'm getting this error:

Server Error
Unable to Connect to ssl://xenforo.com:443. Error #110: Connection timed out

  1. Zend_Http_Client_Adapter_Socket->connect() in Zend/Http/Client.php at line 973
  2. Zend_Http_Client->request() in Hex/InstallUpgrade/Model/InstallUpgrade.php at line 566
  3. Hex_InstallUpgrade_Model_InstallUpgrade->checkForUrl() in Hex/InstallUpgrade/ControllerHelper/InstallUpgrade.php at line 51
  4. Hex_InstallUpgrade_ControllerHelper_InstallUpgrade->checkForUrl() in Hex/InstallUpgrade/Extend/XenForo/ControllerAdmin/AddOn.php at line 389
  5. Hex_InstallUpgrade_Extend_XenForo_ControllerAdmin_AddOn->_checkForUrl() in Hex/InstallUpgrade/Extend/XenForo/ControllerAdmin/AddOn.php at line 180
  6. Hex_InstallUpgrade_Extend_XenForo_ControllerAdmin_AddOn->actionUpgrade() in XenForo/FrontController.php at line 347
  7. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  8. XenForo_FrontController->run() in /home/thebaby/public_html/forum/admin.php at line 13
My ISP says it's not them. Help!


XenForo developer
Staff member
This is really related to your add-on and upgrade tool, but you may be one of the few IPs that have been effectively DoSing us because of a recent update to the tool (that I believe has since been fixed), leading to IPs being blocked at the server level. You should update it.