• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Can't remove a comment/post

#1
I am logged in as main admin, I was testing the comments in resources/articles system with two other non admin user groups. I tested 3 comments and all worked how I wanted them too. When I went in to delete all 3 comments (by checking the box on all three and selecting delete) this is what I got below.

Server Error

Mysqli statement execute error : BIGINT UNSIGNED value is out of range in '(`hmforum_xenforo`.`xf_articles`.`comment_count` - 1)'

  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in Faqe/Articles/DataWriter/Comments.php at line 167
  4. Faqe_Articles_DataWriter_Comments->_postDelete() in XenForo/DataWriter.php at line 1793
  5. XenForo_DataWriter->delete() in Faqe/Articles/ControllerPublic/Comments.php at line 137
  6. Faqe_Articles_ControllerPublic_Comments->actionDelete() in XenForo/FrontController.php at line 351
  7. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  8. XenForo_FrontController->run() in /home/hmforum/public_html/index.php at line 13
It would delete the two that were not in moderation but would not delete the one in moderation. When I tried to delete by just clicking on the delete link and not the check box I get this same error. So I get this error any time I try and do anything with this post/comment.