Fixed Cant Delete Profile Comments

Michael

Active member
When deleting a profile comment I get this error:

Server Error

Undefined property: XenForo_Model_InlineMod_ProfilePost::$enableLogging
  1. XenForo_Application::handlePhpError() in XenForo/Model/InlineMod/ProfilePost.php at line 115
  2. XenForo_Model_InlineMod_ProfilePost->deleteProfilePosts() in XenForo/ControllerPublic/InlineMod/Abstract.php at line 125
  3. XenForo_ControllerPublic_InlineMod_Abstract->executeInlineModAction() in XenForo/ControllerPublic/InlineMod/ProfilePost.php at line 40
  4. XenForo_ControllerPublic_InlineMod_ProfilePost->actionDelete() in XenForo/FrontController.php at line 310
  5. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  6. XenForo_FrontController->run() in /home/xxxxxx/public_html/index.php at line 13
It does seem to go through though and the same happens with undelete too on profile comments. Titles a little misleading there.
 
R

ragtek

Guest
public $enableLogging = true; is missing

XenForo_Model_InlineMod_Thread
XenForo_Model_InlineMod_Post
have this, XenForo_Model_InlineMod_ProfilePost doesn't have this.

so quick fix:
add
PHP:
public $enableLogging = true;
after
PHP:
class XenForo_Model_InlineMod_ProfilePost extends XenForo_Model
{
 
R

ragtek

Guest
Without any modification. Nothing!
Did you really use the INLINEMOD Options for this OR the delete link????

Try to mark several profile posts and delete them via the INLINE MOD controll
inlinemod.png
 

Renada

Active member
public $enableLogging = true; is missing

XenForo_Model_InlineMod_Thread
XenForo_Model_InlineMod_Post
have this, XenForo_Model_InlineMod_ProfilePost doesn't have this.

so quick fix:
add
PHP:
public $enableLogging = true;
after
PHP:
class XenForo_Model_InlineMod_ProfilePost extends XenForo_Model
{
Thanks, works a treat :)
 

shock

Member
public $enableLogging = true; is missing

XenForo_Model_InlineMod_Thread
XenForo_Model_InlineMod_Post
have this, XenForo_Model_InlineMod_ProfilePost doesn't have this.

so quick fix:
add
PHP:
public $enableLogging = true;
after
PHP:
class XenForo_Model_InlineMod_ProfilePost extends XenForo_Model
{
wich file i need to edit?
 
R

ragtek

Guest
XenForo_Model_InlineMod_ProfilePost

library}XenForo\Model\InlineMod\ProfilePost.php

OR
wait for the next beta;)
 

Perspektif

Active member
public $enableLogging = true; is missing

XenForo_Model_InlineMod_Thread
XenForo_Model_InlineMod_Post
have this, XenForo_Model_InlineMod_ProfilePost doesn't have this.

so quick fix:
add
PHP:
public $enableLogging = true;
after
PHP:
class XenForo_Model_InlineMod_ProfilePost extends XenForo_Model
{
thanks
 
Top