1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Can't create a new thread (errno 11)

Discussion in 'Troubleshooting and Problems' started by MsJacquiiC, Jun 12, 2014.

  1. MsJacquiiC

    MsJacquiiC Well-Known Member

    A few times yesterday evening - a client received the following error when posting a new thread:

    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Can't create a new thread (errno 11); if you are not out of available memory, you can consult the manual for a possible OS-dependent bug - library/Zend/Db/Statement/Mysqli.php:214
    Generated By: Unknown Account, Yesterday at 4:22 PM
    Stack Trace
    #0 /home/account/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /home/account/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /home/account/public_html/library/XenForo/Model/Thread.php(2127): Zend_Db_Adapter_Abstract->query('????INSERT DELA...', 479)
    #3 /home/account/public_html/library/XenForo/ControllerPublic/Thread.php(159): XenForo_Model_Thread->logThreadView(479)
    #4 /home/account/public_html/library/XenZine/ControllerPublic/Thread.php(20): XenForo_ControllerPublic_Thread->actionIndex()
    #5 /home/account/public_html/library/XenForo/FrontController.php(347): XenZine_ControllerPublic_Thread->actionIndex()
    #6 /home/account/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #7 /home/account/public_html/index.php(13): XenForo_FrontController->run()
    #8 {main}
    Request State
    array(3) {
      ["url"] => string(108) "http://account.com/index.php?threads/gender-communication-violence-and-bullying-in-online-gaming.479/"
      ["_GET"] => array(1) {
        ["threads/gender-communication-violence-and-bullying-in-online-gaming_479/"] => string(0) ""
      ["_POST"] => array(0) {
    I've seen another thread regarding a similar issue. The thread called such a thing a *server issue* and provided 2 possible reasons for this issue: low RAM memory or low disc space. My server has neither of these. My server has plenty of available RAM and close to 60GB of available disc space.

    So - from my perspective - this doesn't seem an actual server issue at all. If it were a server issue - wouldn't the error occur when posting ALL new threads, and not simply a sporadically occurring error??

    As an FYI ==> The forum in question was recently migrated from a PlanetHippo server. As such - could this issue have anything to do with any specific XF setting or perhaps file permissions or something. IDK. But your help will be most appreciated!

    Thanks ;)

  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. MsJacquiiC

    MsJacquiiC Well-Known Member

    Thanks @Brogan --- Can you be a little more specific as to what "lack of server resources" actually means in this case?
  4. Brogan

    Brogan XenForo Moderator Staff Member

    MsJacquiiC likes this.
  5. RyanC

    RyanC Active Member

    Did you ever find a solution to this problem? @MsJacquiiC
  6. MsJacquiiC

    MsJacquiiC Well-Known Member

    @RyanC ==> Nope. Not particularly.

    I've been told that it's a server resources issue. But my VPS servers are quite robust. I've talked with a few people though - and am currently in talks with my tech support... Apparently I am running some old software on my VPS: MySQL and PHP among them. I've been told that these errors should (ideally) be gone once the software is updated. I suppose we'll see.

    But it's truly a bizarre issue. The errors are sporadically generated. There seems to be no rhyme or reason to them. Are you experiencing the same thing?

  7. dawg

    dawg Well-Known Member

    Convert your database to mariadb and upgrade php to latest stable version

    have you tried that?
    zagorskey and MsJacquiiC like this.
  8. MsJacquiiC

    MsJacquiiC Well-Known Member

    I have no idea what mariadb even is LOL
    I'm not a backend server admin. I just host a handful of clients on my VPS servers... I usually let them run on autopilot. And everything had been just fine until last month when a new client reported the errors in her XF server error log.

    I am indeed planning on upgrading php though. I've had a few people tell me that the issues will likely disappear after I upgrade my server software. Hopefully they are right!

  9. dawg

    dawg Well-Known Member

    The reason i made the suggestion is that i had similar errors after migration. I had tables locking up just like you. I can do a lot on a server but not convert databases either. I had my host do it. After he updated my php and converted my database the problems went away.

    I am no expert here but I am just telling you what worked for me.
    MsJacquiiC likes this.
  10. Tracy Perry

    Tracy Perry Well-Known Member

    Actually... from my understanding, even with the new MariaDB there is no "conversion" required. It should be binary compatible (now, the new 10 series may have broken that somewhat).
    Percona and MariaDB 5.6 compatible version should be just plug and play.

    It appears that the main problem she is having is an OS/mySQL memory error problem in which mySQL is attempting to spawn a thread for a process and cannot as it thinks all memory is in use.
    MsJacquiiC likes this.

Share This Page