1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Failed install "Mark Posts as Best Answer" - can't create new threads?

Discussion in 'Troubleshooting and Problems' started by DroidOne, Nov 30, 2014.

  1. DroidOne

    DroidOne Well-Known Member

    I tried to install v 1.5.1 of the addon "Mark Posts as Best Answer" today together with XF 1.4.2.

    The installation failed after about ~3 seconds displaying this:

    Server Error
    Mysqli statement execute error : Got error 64 'Temp file write failure' from InnoDB
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in BestAnswer/Installer.php at line 48
    call_user_func() in XenForo/Model/AddOn.php at line 215
    XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 187
    XenForo_ControllerAdmin_AddOn->actionInstall() in XenForo/FrontController.php at line 347
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /var/www/site.se/forum/admin.php at line 13
    I noticed that members couldn't create new threads afterwards and since I had no option of uninstalling the addon I decided to install version 1.4.1. That worked, but after uninstalling it via the addon manager, the problem with creating new threads persist.

    The error which reads "Field 'alternative_best_answers' doesn't have a default value" looks like this:

    Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Field 'alternative_best_answers' doesn't have a default value - library/Zend/Db/Statement/Mysqli.php:214
    Generated By: canfield, 1 minut sedan
    Stack Trace
    #0 /var/www/site.se/forum/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /var/www/sitese/forum/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /var/www/site.se/forum/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
    #3 /var/www/site.se/forum/library/XenForo/DataWriter.php(1624): Zend_Db_Adapter_Abstract->insert('xf_thread', Array)
    #4 /var/www/site.se/forum/library/XenForo/DataWriter.php(1613): XenForo_DataWriter->_insert()
    #5 /var/www/site.se/forum/library/XenForo/DataWriter.php(1405): XenForo_DataWriter->_save()
    #6 /var/www/site.se/forum/library/XenForo/ControllerPublic/Forum.php(728): XenForo_DataWriter->save()
    #7 /var/www/site.se/forum/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Forum->actionAddThread()
    #8 /var/www/site.se/forum/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #9 /var/www/site.se/forum/index.php(13): XenForo_FrontController->run()
    #10 {main}
    Can anyone help me fix this?
    Last edited: Nov 30, 2014
  2. Amaury

    Amaury Well-Known Member

    You'll need to ask in the add-on thread for support.
    DroidOne likes this.
  3. dicot

    dicot Member

Share This Page