• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Cannot send any forum emails

#1
I've launched a new forum, and I'm getting an error I've never seen before. It looks like there's something wrong with the sendmail.php file, but as I'm not fluent in the ways of PHP, I have no idea why this is happening.

Code:
Zend_Mail_Transport_Exception: Email to me@myemail.com failed: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137

#0 /var/www/sites/skyhavenmc.com/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /var/www/sites/skyhavenmc.com/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /var/www/sites/skyhavenmc.com/library/XenForo/Deferred/UserEmail.php(168): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
#3 /var/www/sites/skyhavenmc.com/library/XenForo/Deferred/UserEmail.php(62): XenForo_Deferred_UserEmail->_sendEmail(Array, Array, Object(Zend_Mail_Transport_Sendmail))
#4 /var/www/sites/skyhavenmc.com/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_UserEmail->execute(Array, Array, 7.8949179649353, '')
#5 /var/www/sites/skyhavenmc.com/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.8949179649353, '', false)
#6 /var/www/sites/skyhavenmc.com/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 7.8949189186096, '', false)
#7 /var/www/sites/skyhavenmc.com/library/XenForo/ViewRenderer/Abstract.php(352): XenForo_Model_Deferred->run(true, 7.8949189186096)
#8 /var/www/sites/skyhavenmc.com/library/XenForo/ViewRenderer/HtmlAdmin.php(50): XenForo_ViewRenderer_Abstract::hasManualDeferredToRun()
#9 /var/www/sites/skyhavenmc.com/library/XenForo/FrontController.php(616): XenForo_ViewRenderer_HtmlAdmin->renderRedirect(4, 'http://skyhaven...', NULL, Array)
#10 /var/www/sites/skyhavenmc.com/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_Redirect), Object(XenForo_ViewRenderer_HtmlAdmin), Array)
#11 /var/www/sites/skyhavenmc.com/admin.php(13): XenForo_FrontController->run()
#12 {main}
 

Brogan

XenForo moderator
Staff member
#2
You are using the PHP mail function so XenForo passes the email to sendmail or the equivalent on the server.

The failure is at the server level, you can check the server mail log to see why it is failing.

Your host should be able to help with that.
 
#3
You are using the PHP mail function so XenForo passes the email to sendmail or the equivalent on the server.

The failure is at the server level, you can check the server mail log to see why it is failing.

Your host should be able to help with that.
I'm hosting this myself, so where would I find the mail log? The mail is hosted through someone else though, just to clarify.