1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Service Issue Cannot select categories and albums on some Android tablets

Discussion in 'Media Gallery Bug Reports' started by Martok, Aug 19, 2015.

  1. Martok

    Martok Well-Known Member

    I'm not sure if this is a bug, a browser issue or a device issue. I've posted in bug reports to start and see where this goes.

    I have a Sony Xperia Z3 compact tablet running Android 5.1.1 and I have discovered that, when adding media to the Gallery, I cannot select the category or album that I want it to go in. When I tap on any of the categories, they briefly change the background colour as though they are being selected but almost immediately return to their original state.


    The browser being used is the latest version of Chrome for Android (version 44) though I've also tested it with version 42. The browser isn't requesting the desktop version of the site, though ticking this option doesn't make a difference.

    I tried replicating this on my Xperia Z1 compact phone running Android 4.4.4 using Chrome for Android 44, though this uses the 'pop out' menu system that small mobiles use rather than the one above. However when I switched the browser to desktop mode on my phone, I had the same issue as above.

    I also tried replicating the issue on a Nexus 7 (2012) which is also running Android 5.1.1 and using Chrome for Android 44. Although I couldn't completely replicate the issue (I also tried with desktop mode enabled) I did find that sometimes when I tapped on a category or album it didn't select, though most of the time it did.

    The above does seem to suggest that it could be something to do with Chrome on Sony devices, but the partial issue on a Nexus 7 could mean that it's something else.

    This issue was tested on XenForo Media Gallery 1.0.9 on my site and 1.1.0 here on XenForo.
  2. Mike

    Mike XenForo Developer Staff Member

    I've reproduced the Nexus 7 issue, though only very infrequently. It seems that when I reproduce it, I can reproduce it a couple times, but only with the lightest of taps (and still infrequently); a "normal" tap was sufficient to clear it up.
  3. Martok

    Martok Well-Known Member

    I found it similar with the Nexus 7, though it wasn't always a very light tap. A heavier tap usually did clear things up.

    I'm really stuck though with my Xperia Z3 compact tablet though (the Xperia Z1 phone is fine as long as I don't request desktop mode). I have no idea why it just highlights a category very briefly but won't select it. Multiple taps and heavy presses just will not select a category.
  4. Chris D

    Chris D XenForo Developer Staff Member


    Can you confirm that the issue here is the same one that is affecting your Xperia Z3?


    If you could just clarify the following, too:
    If you could get your user agent, too, while using the tablet from: http://whatsmyuseragent.com/

    Ultimately, I think we are likely going to need to attempt to block these devices, but it is comforting to know, at least, that the developers of the library are potentially looking into it.

    With your permission, I'll pass any info you give me directly on to them as it may help their efforts.
  5. Martok

    Martok Well-Known Member

    @Chris D yes, this is the same issue.

    I've checked on the Chosen demo page and the issue still remains, I can't select anything from the Chosen lists on the right hand side.

    My user agent is:

    Mozilla/5.0 (Linux; Android 5.1.1; SGP612 Build/23.4.A.1.200) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.76 Safari/537.36

    You are welcome to pass on this information.

    Incidentally the workaround for this is to start typing in a category until it highlights it (as shown below). Then hitting return selects the category, allowing media to be added to the category.

    Chris D likes this.

Share This Page