1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot create child style

Discussion in 'XenForo Questions and Support' started by Mike Creuzer, Mar 28, 2012.

  1. Mike Creuzer

    Mike Creuzer Well-Known Member

    Hello,

    I get the following error when I try to create a child style:
    Code:
    An exception occurred: Mysqli prepare error: MySQL server has gone away in C:\wamp\www\software\xenforo\1.1\library\Zend\Db\Statement\Mysqli.php on line 77
     
    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Error.php at line 50
    XenForo_Error::unexpectedException() in XenForo/Application.php at line 295
    XenForo_Application::handleException()
    I have 13 styles installed. I'm on localhost.

    Thanks,
    Mike
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Mike Creuzer

    Mike Creuzer Well-Known Member

    But isn't this a different error? Apparently not, but it looked different :p. I increased max_allowed_packet to 10M and it worked perfectly. Would you recommend changing anything else?
     
  4. Mike Creuzer

    Mike Creuzer Well-Known Member

    Fatal error: Maximum execution time of 60 seconds exceeded in C:\wamp\www\software\xenforo\1.1\library\Zend\Db\Statement\Mysqli.php on line 104

    Cannot get by this one. Another issue with having skins? I only have around ten. Do I need to remove all skins when Im done working with them? The days of having dozens of skins is over? :p
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

  6. Mike Creuzer

    Mike Creuzer Well-Known Member

    Fatal error: Maximum execution time of 60 seconds exceeded in C:\wamp\www\software\xenforo\1.1\library\XenForo\Template\Compiler\Tag\If.php on line 104

    After setting max_execution_time = 180
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Some hosts don't allow you to override the PHP configuration. Visit admin.php?tools/phpinfo to confirm that the new value is showing for that setting.
     
  8. Mike Creuzer

    Mike Creuzer Well-Known Member

    Thanks Jake, and I'm on localhost so it does show the value changed.
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Then this error shouldn't be:

    Maybe it's an old error in the log? From before the change.
     
  10. Mike Creuzer

    Mike Creuzer Well-Known Member

    Well I restarted all services, still getting:

    Fatal error: Maximum execution time of 60 seconds exceeded in C:\wamp\www\software\xenforo\1.1\library\Zend\Db\Adapter\Abstract.php on line 473

    But that line is showing as changed in php.ini and phpinfo(). Sorry this might be an easy fix, not really too involved on some of these things.
     
  11. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    [​IMG]

    Well, the change isn't taking effect for some reason.

    I say you should delete some styles. :D
     
  12. Mike Creuzer

    Mike Creuzer Well-Known Member

    Lol! Well if I must. I do hope that one day I wont have to as it would make development that much easier, but if thats the best complaint I have Ill take it any day! :D
     
  13. Dinh Thanh

    Dinh Thanh Well-Known Member

    This error come from Mysql, not php.
    Change these values in my.cnf to:

    wait_timeout = 600
    connect_timeout = 120

    Hope it help.
     
  14. Mike Creuzer

    Mike Creuzer Well-Known Member

    Thanks, but where do I find this file? Google wasn't much of a help with this. Im running wamp.
     
  15. bambua

    bambua Well-Known Member

    On linux it's usually in /etc/my.c
    nf I think I missed in your post what type of environment you are developing in?
     
  16. Dinh Thanh

    Dinh Thanh Well-Known Member

    It's /etc/my.cnf (linux, mac)

    Windows are different, should check this: http://www.tikalk.com/net/blog/where-my-mycnf-file
    C:\WINNT\my.ini C:\WINNT\my.cnf C:\my.ini C:\my.cnf
    C:\Program Files\MySQL\MySQL Server 5.0\my.ini
    C:\Program Files\MySQL\MySQL Server 5.0\my.cnf
     
  17. Mike Creuzer

    Mike Creuzer Well-Known Member

    Im running wampserver. I did a search inside the folder for said file with no luck. I do have a my.ini file, but in that file I do not have the options that you've presented.
     
  18. Dinh Thanh

    Dinh Thanh Well-Known Member

    You should add them then restart mysql.
    wait_timeout = 600
    connect_timeout = 120
     
    Mike Creuzer likes this.
  19. MagnusB

    MagnusB Well-Known Member

    Just a quick google found that it is called my.ini on Windows, and is located in xammp/mysql/bin/my.ini for wamp :)
     
    Mike Creuzer likes this.

Share This Page