1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 cannot connect to host; error = (errno = 0 )

Discussion in 'Troubleshooting and Problems' started by giorgino, Feb 6, 2016.

  1. giorgino

    giorgino Well-Known Member

    I've just changed dedicated server and now I got this error :(
    php 5.6 xenforo 1.4 and 1.5 Apache 2.4 CentOs6 64bit

    cannot connect to host; error = (errno = 0 )

    #0 /home/immobili/public_html/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('mail.immobilio....', 993, 'SSL')
    #1 /home/immobili/public_html/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Array)
    #2 /home/immobili/public_html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #3 /home/immobili/public_html/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.99999785423, '')
    #4 /home/immobili/public_html/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.99999785423, '', false)
    #5 /home/immobili/public_html/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #6 /home/immobili/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #7 {main}

    array(3) {
    ["url"] => string(37) "https://www.immobilio.it/deferred.php"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(47) "/threads/sentenza-n-18135-del-16-09-2015.35434/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }


    What's wrong?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. giorgino

    giorgino Well-Known Member

    I've seen that thread @Brogan, thank you for replay, but no dice in my configuration... and that's why I opened this new thread...
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    By chance are you using a firewall - and if so, is the outbound ports that you are using for your IMAP connection open for outbound (from the server) in that firewall?
     
  5. giorgino

    giorgino Well-Known Member

    Port open...
    For now I've solved the issue setting the port at 25 in the bounce mail setting...
     

Share This Page