1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Cannot cache sessions with Libmemcached

Discussion in 'Troubleshooting and Problems' started by Floren, Jul 13, 2012.

  1. Floren

    Floren Well-Known Member


    I was wondering what is the proper configuration for Libmemcached. Right now everything works proper, except that I cannot cache the sessions. This is what I have setup as options, in one of my development servers:
    $config['cache']['enabled'] = true;
    $config['cache']['cacheSessions'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] = array(
    	'caching'			=> true,
    	'cache_id_prefix'		=> 'xf_',
    	'automatic_serialization'	=> true,
    	'lifetime'			=> 0
    $config['cache']['backend'] = 'Libmemcached';
    $config['cache']['backendOptions'] = array(
    	'servers'	=> array(
    			'host'		=> '',
    			'port'		=> 11211,
    			'weight'	=> 1
    Thanks for your help.
  2. Floren

    Floren Well-Known Member

    Any of the mods can test it in their environment and confirn that this is not a bug? Thanks.
    If you miss the rpm's, you can get them from Axivo.

    Edit: I got it working, thanks guys. Libmemcached is much more robust, compared to Memcached.
  3. Kintaro

    Kintaro Well-Known Member

    same problem with xcache... I can't login. how do you solved?

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Generally that means your cache is not healthy. For example, if the cache is too small such that it keeps getting full then that will cause login problems if you store session records in that cache. You need to check the status of your cache to make sure it's healthy.
  5. Fred.

    Fred. Well-Known Member

    @Floren I have the same problem now.
    Can you give me a hint? :D Not sure why it's not working.
    I doubled my cache to 256MB and that should be more than enough for my small forum. But that doesn't fix the problem.

    If I disable
    $config['cache']['cacheSessions'] = true;
    It's working perfect.

Share This Page