1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Can only have one +1 button per page!

Discussion in 'Resolved Bug Reports' started by Jaxel, Jul 6, 2011.

  1. Jaxel

    Jaxel Well-Known Member

    I have this: http://8wayrun.com/

    Each article has a Google +1 button... however, the URL from the LAST +1 button on the page is being inserted into every +1 button, instead of each button having it's own URL.
     
  2. Wuebit

    Wuebit Well-Known Member

    Try href= not data-url=
     
  3. Jaxel

    Jaxel Well-Known Member

    Doesnt make a difference.... This is the code I am using...

    Code:
    <xen:foreach loop="$RecentNews" value="$news">
        .
        .
        .
        <div class="g-plusone" data-size="medium" data-count="true" data-url="{xen:link canonical:threads, $news}" data-lang="{$visitorLanguage.language_code}"></div>
        .
        .
        .
    </xen:foreach>
     
  4. Jaxel

    Jaxel Well-Known Member

    figured it out... data-href= works...

    XenForo is using data-url=, which is a bug... it should be using data-href=

    If it doesn't find data-href=, it uses the current page its on... which silently fails; into success on normal pages. But its just bad form.
     
  5. Wuebit

    Wuebit Well-Known Member

    Cool :) thought it was href.
     
  6. Gustavo Fernandez

    Gustavo Fernandez Active Member

    Code:
    <xen:foreach loop="$RecentNews" value="$news">
        .
        .
        .
        <div class="g-plusone" data-size="medium" data-count="true" data-url="{xen:link canonical:threads, $news}" data-lang="{$visitorLanguage.language_code}"></div>
        .
        .
        .
    </xen:foreach>
    How do I do in Spanish?
     
  7. Romchik®

    Romchik® Well-Known Member

    Code:
    <script type="text/javascript" src="https://apis.google.com/js/plusone.js">
      {lang: 'es'}
    </script>
    Or wait 1.0.4 or 1.1.0.
     
    Vincent likes this.
  8. Gustavo Fernandez

    Gustavo Fernandez Active Member

    Where Do I Paste this code?
     
  9. Kier

    Kier XenForo Developer Staff Member

    All fixed in 1.0.4
     
  10. Gustavo Fernandez

    Gustavo Fernandez Active Member

    when will it be ready?
     

Share This Page