• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed  Can only have one +1 button per page!

Jaxel

Well-known member
#1
I have this: http://8wayrun.com/

Each article has a Google +1 button... however, the URL from the LAST +1 button on the page is being inserted into every +1 button, instead of each button having it's own URL.
 

Jaxel

Well-known member
#3
Try href= not data-url=
Doesnt make a difference.... This is the code I am using...

Code:
<xen:foreach loop="$RecentNews" value="$news">
    .
    .
    .
    <div class="g-plusone" data-size="medium" data-count="true" data-url="{xen:link canonical:threads, $news}" data-lang="{$visitorLanguage.language_code}"></div>
    .
    .
    .
</xen:foreach>
 

Jaxel

Well-known member
#4
figured it out... data-href= works...

XenForo is using data-url=, which is a bug... it should be using data-href=

If it doesn't find data-href=, it uses the current page its on... which silently fails; into success on normal pages. But its just bad form.
 

Wuebit

Well-known member
#5
figured it out... data-href= works...

XenForo is using data-url=, which is a bug... it should be using data-href=

If it doesn't find data-href=, it uses the current page its on... which silently fails; into success on normal pages. But its just bad form.
Cool :) thought it was href.
 
#6
Code:
<xen:foreach loop="$RecentNews" value="$news">
    .
    .
    .
    <div class="g-plusone" data-size="medium" data-count="true" data-url="{xen:link canonical:threads, $news}" data-lang="{$visitorLanguage.language_code}"></div>
    .
    .
    .
</xen:foreach>
How do I do in Spanish?