1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can only access my website on certain networks

Discussion in 'Server Configuration and Hosting' started by Jeanz, Sep 3, 2014.

  1. Jeanz

    Jeanz Member

    I'm sorry if this is the wrong thread, I'm just really at a point where I don't know what to do anymore. No one I have talked to has ever had a issue like this.

    Since I got home from a vaccation last friday, I haven't been able to visit my website. Every other website works fine, but mine just loads for a long time and them says the website is unavailable. If I try on my phone with the wifi turned on, the issue is the exact same, tried two other computers as well, still the same..

    Then if I turn off wifi on my phone, and just use the phones own internet, the website works fine. I tried asking some people using different networks (ISP Providers), if they could see the page. And they could. Tried proxy server pages too, works fine also. So I thought the problem what that my ISP Provider or my router had blocked the page. But they can't find the problem either.

    I then later on, found out that another person with the same ISP Provider as me, had the same issue as me. The person lives in a different part of the country away from me, so it just seemed strange that she has the exact same problem. I was then sure that the ISP Provider had blocked the site for all of their customers. But then yesterday, when going to school I have the some problem there, and they claim to have a completely different ISP Provider.

    I have of course been in contact with my host, who no longer know what to do, and has basically said it's not their problem, as the DNS works fine, and I can ping the domain, but not access it through the browser. Tried different browsers of course. And a bunch of other stuff both my host and ISP Provider asked me to try. But at this point nobody knows what the problem is.

    Has anyone ever had this issue, or know what could be wrong? It's so weird. that the page works perfect using some networks, and not at all using others. On the networks that don't work, I can't use FTP or cPanel either, but using the networks that I can access it with, those things works without problems too.

    I'm begging for help.. :(:(:(:(:(

    The problem is with my XenForo website http://www.avrillavigne.dk
  2. wickedstangs

    wickedstangs Well-Known Member

    your ip might be blocked at your hosting happens to me sometimes... when I do to many FTP attempts. Contact your hosting.
  3. Jeanz

    Jeanz Member

    But it is not just me, there a other people not able to see the website either, from different IP's. But that was the first thing I contacted them about, and they aren't blocking me. I think we have tried everything we can think of being the issue.
  4. Snog

    Snog Well-Known Member

    Try changing your DNS servers on your computer to Google's DNS servers ( and to see if it's a DNS problem with your provider. If you can view your site after doing that, then there's a definite problem with your ISP's DNS.

    If you can't view the site, look into your server's DNS, there may be a problem with that.
  5. FredC

    FredC Well-Known Member

    It sounds to me like your DNS settings are not resolving with your ISP.. I wouldn't put to much stock in what your host is saying about their servers.. Ive found most to be as clueless on the subject as i am.. (and that's not good) :) good luck wish i could be of some actual assistance.
  6. Jeanz

    Jeanz Member

    My ISP Provider asked me to do this, and it didn't change anything, it still didn't work. The strange thing is, that it works for some people, and not for others. The website works fine for me if I use my phones internet and share it with my computer. Then I can access the page just fine using my PC. But other people in different part of my country are having the same problem with the site.
  7. Jeanz

    Jeanz Member

    My host said the DNS works perfectly, and they seem a bit irritated that I keep contacting them about this issue, as they don't believe they are the problem. o_O But thanks for the reply, I really hope I find a solution to this problem soon. :)
  8. Snog

    Snog Well-Known Member

    I'm not sure where you're from, but is it possible there's a government agency blocking the site for some reason?
  9. Jeanz

    Jeanz Member

    I'm from Denmark. It's just a simple Avril Lavigne fansite, nothing that could break any sort of rules. It works fine on most danish networks, but the one I'm using called "Stofa" dosen't work. I know I could just change ISP Provider, but then there is still a huge problem for my users also using "Stofa" as ISP Provider.
  10. Snog

    Snog Well-Known Member

    Do you have any 'Discouraged' IP addresses set in Admin->Users->Discouraged IP Addresses?

    It's possible you discouraged your own IP block using a wildcard and that could cause what's happening to you.
  11. Jeanz

    Jeanz Member

    That's a great suggestion. I just checked that, and also banned IP's to be sure, but my own IP is not among those.
  12. Snog

    Snog Well-Known Member

    Well, then that really only leaves a few possibilities and any of them mean someone is lying to you..

    1) Your ISP's DNS is not working properly (but you changed to Google DNS on your computer so that shouldn't be it)
    2) Your server has a firewall blocking your IP address range.
    3) Your ISP is blocking the IP address range of your server for some reason.

    But there is one thing that does bother me about your server's DNS settings. The nameservers are on a single point of failure. That tends to tell me you're on a host that is reselling web space or you're hosting your own DNS server...

  13. Jeanz

    Jeanz Member

    I'm suspecting your option number 3, I am waiting for my ISP Provider to contact me, apparently they are busy so it takes ages for them to get back to me. I talked to them for over an hour monday, and I just figure that checking for blocked IP would have been some of the first things they would have done? But I will try to get them to look into it again. My host said they aren't blocking me, and told me they had made sure I will not be blocked in the future, to make sure they are not the problem. I'm using HostMantis.com shared hosting.
  14. Alex - A2Hosting

    Alex - A2Hosting Active Member

    Are you on a shared hosting enviroment? If so, whitelisting IP addresses on request should raise a red flag (unless you have a VPS or Dedicated server with them).

    Have you tried running a tracert from any network that is blocked to see where the issue actually is?
  15. Jeanz

    Jeanz Member

    Yes, I'm using shared hosting. And yes, they have had to whitelist some rules a few times that was blocking me from updating things in my xenforo adminpanel (got a forbidden error). Is that a bad thing?
    I remember trying the tracert command while on the phone with my ISP Provider, but I don't remember what the results where. I'm not really good at all that cmd stuff. But tried it again, don't know if you can make anything of it. Sorry for my cmd being in danish.

    tracert www.avrillavigne.dk

    Sporer rute til avrillavigne.dk []

    over et maksimum af 30 hop:

    1 16 ms 50 ms 40 ms

    2 8 ms 7 ms 18 ms

    3 8 ms 16 ms 10 ms vlan116.core-aalb-1.stofa.net []

    4 14 ms 10 ms 17 ms

    5 20 ms 43 ms 19 ms dk-aal-a2-serial6-7-access.aalborg.dk.telia.net []

    6 * * * Anmodning fik timeout.

    7 18 ms 23 ms 18 ms kbn-b1-geth2-3.telia.net []

    8 57 ms 48 ms 37 ms kbn-bb4-link.telia.net []

    9 34 ms 25 ms 20 ms s-bb4-link.telia.net []

    10 27 ms 44 ms 31 ms s-b5-link.telia.net []

    11 44 ms 80 ms 42 ms s-akix-i1-link.telia.net []

    12 46 ms 48 ms 76 ms as5580-ic-155269-s-akix-i1.c.telia.net []

    13 41 ms 50 ms 40 ms eth2-4.edge1.sto1.se.as5580.net []

    14 41 ms 38 ms 38 ms eth15-2.r1.fra1.de.as5580.net []

    15 45 ms 44 ms 51 ms eth1-3.edge1.fra6.de.as5580.net []

    16 41 ms 63 ms 50 ms eth11-1.core1.ams1.nl.as5580.net []

    17 53 ms 40 ms 44 ms eth2-2.r1.ams1.nl.as5580.net []

    18 48 ms 39 ms 77 ms

    19 43 ms 40 ms 52 ms amsrv20.fastcpanelserver.com []

    Sporing fuldført.
  16. Jeanz

    Jeanz Member

    Does anyone know if moving to a different host could make these problems go away? I know my host said they are not the problem, but since i can't find out what the problem is, I just have to do something! It sucks having a website that only some of my users can access! (n)
  17. Tracy Perry

    Tracy Perry Well-Known Member

    That would be one thing to try... you could get a shared month-month hosting from another provider and then set up a test site on it (you would need to password protect access to the forum via .htaccess to be in compliance with XenForo licensing) and see if you can access it. If so, then that tells you that your current hosting provider is being blocked at some point in the chain from your ISP provider (possibly even by the host providers firewall).

    Since you said you were not familiar/comfortable with using CLI... but you could get a VPS configured with cPanel and be at something you are familiar with - but you still have to do the backend maintenance on the VPS.
  18. WSWD

    WSWD Well-Known Member

    I would say this is a host issue as well. Those traceroutes (assuming you are getting the traceroute using the same computer/network where you can't access your site) are making it to the server.
    If they truly exhausted every possibility, then who the hell knows? The Internet does strange things sometimes. :) But the fact that some people can access it and some can't, that's just bizarre. It makes no sense at all. The fact that the trace is making it to the server really does point to a firewall issue on the server, IP being blocked by CSF, or something similar.
  19. Jeanz

    Jeanz Member

    I have now changed host to bigwetfish.co.uk, they where extremely helpful in migrating my website. :)
    I still don't know what the problem was, but now after changeing host everything works perfectly again! :)

    Thank you all for replying! :)

Share This Page