• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Can I downgrade from 1.2

#1
Just upgraded but it just destroys nearly every add on I had installed. More fool me for not testing it first...
I would like to downgrade to 1.5... is that possible?
 

MattW

Well-known member
#2
http://xenforo.com/community/thread...ate-2-released-unsupported.55456/#post-590977

This warning has been in all 1.2 releases so far:
This is Unsupported Software

While we have moved on from the beta distinction, please remember that this release is not officially supported and we do not recommend running pre-release software in a production environment. Support is limited at this time to questions here on the community forums.

Expect many add-ons and styles to be broken after upgrading to 1.2. You must test your add-ons thoroughly or look for updates. Be especially careful with add-ons that cover similar features to ones that are added to 1.2; these may conflict with the core XenForo data. If data conflicts are found, they will need to be resolved in a new add-on release or by removing the add-on before upgrading to 1.2.

If you choose to run unsupported software, it is your responsibility to ensure that you make a backup of your data. We recommend you do this before attempting an upgrade.
What add-ons are broken?
 
#3
yeah I know - its my own fault.
xenporta will not work, xenmoods messes up text on member page, TMS, and WORST of all it appears postloop is not supported in 1.2 (that is a killer for me as I am building up my forum), online status add on messes up text.
 

MattW

Well-known member
#4
TMS isn't needed in 1.2
I've posted the fixes for xenmoods in that thread.
Online status is probably a small fix due to a template change.
Can't comment on XenPorta or postloop as I don't use either of them.

Did you take a back up before doing the upgrade?
 
#5
TMS isn't needed in 1.2
I've posted the fixes for xenmoods in that thread.
Online status is probably a small fix due to a template change.
Can't comment on XenPorta or postloop as I don't use either of them.

Did you take a back up before doing the upgrade?
No - I didn't :(
the fixes you gave for xenmoods were for the member pop up, not the member page.
Also I still have a TMS option in my admin - even though I uninstalled it - just takes me to an error page.

Sorry - I know its unsupported at present - my mistake. I take it there is no way to downgrade back to 1.5.x
 

MattW

Well-known member
#6
http://xenforo.com/community/threads/xenmoods.26688/page-26#post-592462

That is the post I linked to.

You can also download the XML file I uploaded in the zip, as that will automatically fix both of them.

XenForo 1.2 has it's own Template Modification system, which has the same name in the ACP as TMS. See this excellent resource from @Chris Deeming : http://xenforo.com/community/resources/a-guide-to-xenforo-1-2-and-templates.2115/ That should clear up any confusion with it.

I don't think you can downgrade back to 1.1.5 from 1.2, you would have to roll back using an backup of the database and the forum files.
 

Brogan

XenForo moderator
Staff member
#8
I don't think you can downgrade back to 1.1.5 from 1.2, you would have to roll back using an backup of the database and the forum files.
Correct.
The only way to "downgrade" is by restoring a backup and replacing the server files.