• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Cakeday

Cakeday 3.6.12

No permission to download

alexD

Well-known member
#1
alexD submitted a new resource:

Cakeday - Users are important, show them they matter to you.

The Cakeday add-on for XenForo 2

View attachment 157480

Features

  • Display cakeday icons on posts made by celebrating users
  • Option to use FontAwesome or any kind of text (e.g. emojis) to signal the anniversary
  • Developed using the best practices of the new XF2 framework (template macros, class extensions, etc.)
  • Easy to modify templates and translatable...
Read more about this resource...
 
#4
Hey alexD, i tried installing it and i get this,

XF\Db\Exception: MySQL query error [1366]: Incorrect string value: '\xF0\x9F\x8E\x82 \xF0...' for column 'phrase_text' at row 1 in src/XF/Db/AbstractStatement.php at line 183

and when i try removing it, i get an error too with the same message as above, and when i completely remove the file from /src/addons/ and when i click a post on the forums i can't see the post it says

Exception: Could not find class Datio\Cakeday\XF\Entity\Post when attempting to extend XF\Entity\Post in src/XF/Extension.php at line 174
 
Last edited:

alexD

Well-known member
#5
@Joeychgo No XF 1.x version of this add-on is planned, unless sponsored.

@Pur3x Make sure your database is using the utf8mb4 character set.

About the second error, try to re-install the add-on. Then, disable it and uninstall it afterwards.
I just uninstalled and re-installed it normally and had no issues, thus I suspect it's again a server configuration issue on your end.
 
#6


[USER=139534]@Pur3x
Make sure your database is using the utf8mb4 character set.

About the second error, try to re-install the add-on. Then, disable it and uninstall it afterwards.
I just uninstalled and re-installed it normally and had no issues, thus I suspect it's again a server configuration issue on your end.
The db is running that character set, as you can see , and i tried disabling and uninstalling and reinstalling it and still the same error.
 

alexD

Well-known member
#7
I think I troubleshooted your issue.

When I try to change the xf_phrase table collation from utfmb4 to utf8, I get the same error:
xF0...' for column 'phrase_text' at row 1.png

You can verify the table's collation by running the following SQL command:
Code:
SHOW FULL COLUMNS FROM xf_phrase;
SHOW FULL COLUMNS FROM xf_phrase;.png
 
#13
Which versions of php and mysql/mariadb do you run? Are you using apache, nginx, or something else?
Apache Version: 2.4.27
PHP Version: 5.6.31
MySQL Version: 10.0.32-MariaDB

Using beta 2 xf, and your current addon, install the addon and then it breaks as its importing permissions.
 

alexD

Well-known member
#16
@Pur3x & @Titans you both need to add the following line to your config.php for the add-on to work:
Code:
$config['fullUnicode'] = true;


Any ideas ? lol Any addons i uninstall now i have problems with because of this addon
You can delete the phrases that trigger the error by executing the following MySQL query:
Code:
DELETE FROM xf_phrase WHERE addon_id = 'Datio/Cakeday';
 

Attachments

#17
@Pur3x & @Titans you both need to add the following line to your config.php for the add-on to work:
Code:
$config['fullUnicode'] = true;



You can delete the phrases that trigger the error by executing the following MySQL query:
Code:
DELETE FROM xf_phrase WHERE addon_id = 'Datio/Cakeday';
That did it, tyvm, it works now.