• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 bug with google+

Tealk

Active member
#1
if user try to register with google+ they get this error:

Code:
 Fehler:invalid_client
no registered origin
Details anfordern
scope=https://www.googleapis.com/auth/plus.login https://www.googleapis.com/auth/userinfo.email https://www.googleapis.com/auth/plus.moments.write https://www.googleapis.com/auth/plus.me https://www.googleapis.com/auth/plus.profile.agerange.read https://www.googleapis.com/auth/plus.profile.language.read https://www.googleapis.com/auth/plus.circles.members.read
redirect_uri=postmessage
origin=http://www.anzahcraft.de
state=721034472|0.1727577448
display=page
request_visible_actions=http://schemas.google.com/AddActivity
hl=de-DE
cookie_policy_enforce=false
response_type=code token id_token gsession
access_type=offline
cookie_policy=single_host_origin
proxy=oauth2relay1728924380
include_granted_scopes=true
client_id=1033497507051.apps.googleusercontent.com
authuser=0
 

Echelon

Active member
#3
I don't get any error....in fact...i do not get any result from google+......looks like the link isn't working when i want to login or register with goorle+. also when i want to associate my google+ account....link seems to be dead.

I am pretty sure my setup is correct

can someone give me a solution?

i used to use the add on from guiltar and worked like a charm.....no it's not


gplus3.png





gplus2.png






gplus.png
 

Chris D

XenForo developer
Staff member
#4
First of all, you'll want to log in to Google and regenerate those API keys now or create new ones. Always keep those private, especially the one that clearly states it is a "Secret" ;) As it stands right now, someone could use those secret keys and potentially spoof your app.

The Log in button for Google works a little differently to the others. It gets fired via JavaScript.

Once you have clicked the button and nothing has happened, check your browser console (F12) and see if any errors have been logged.
 

Echelon

Active member
#5
First of all, you'll want to log in to Google and regenerate those API keys now or create new ones. Always keep those private, especially the one that clearly states it is a "Secret" ;) As it stands right now, someone could use those secret keys and potentially spoof your app.

The Log in button for Google works a little differently to the others. It gets fired via JavaScript.

Once you have clicked the button and nothing has happened, check your browser console (F12) and see if any errors have been logged.
I will regenerate the api keys and see what happens next...thanks for your help
 

Chris D

XenForo developer
Staff member
#6
I know what your site URL is... I've just checked out your site.

I noticed that your board is closed at the moment. If you open the board, does it make any difference? I don't think it will, but just wanted to check.

Also, you seem to have some non-standard social buttons that may be interrupting the XenForo JS. Could you try again with these buttons disabled?
 

Echelon

Active member
#7
I know what your site URL is... I've just checked out your site.

I noticed that your board is closed at the moment. If you open the board, does it make any difference? I don't think it will, but just wanted to check.

Well....facebook and twitter work fine...even when the board is closed but i will give it a try.


Also, you seem to have some non-standard social buttons that may be interrupting the XenForo JS. Could you try again with these buttons disabled?
which buttons you refering to exactly...the ones on the right in the header?
well....i cannot disable them since it's a customized script.

also....google+ worked perfectly with the guiltar addon...even with the non standard social buttons
 

Chris D

XenForo developer
Staff member
#8
Yes the top right header sharing buttons.

Anything that is non-standard can be disabled. Do you still have the XenForo Default Style available? Presumably you added those buttons to the Style you have enabled by default. Does it work OK if you try the default style?

The implementation in the guiltar add-on is outdated and will stop working when Google make a number of changes to its API this year.
 

Echelon

Active member
#9
Yes the top right header sharing buttons.

i cannot disable them....they are way too important for us....just cannot do that

Anything that is non-standard can be disabled. Do you still have the XenForo Default Style available? Presumably you added those buttons to the Style you have enabled by default. Does it work OK if you try the default style?

YES. it works okay wth the default style on.....

what do i do next?

The implementation in the guiltar add-on is outdated and will stop working when Google make a number of changes to its API this year.
 

Chris D

XenForo developer
Staff member
#10
If it works ok on the default style, then the issue is caused by something that is in your custom style that isn't in the default style. It's also most likely JavaScript related.

Therefore I have to say that it may well be the custom share button script you're using. The only way to be sure is to somehow disable it - or remove it if that isn't possible.
 

Echelon

Active member
#11
If it works ok on the default style, then the issue is caused by something that is in your custom style that isn't in the default style. It's also most likely JavaScript related.

Therefore I have to say that it may well be the custom share button script you're using. The only way to be sure is to somehow disable it - or remove it if that isn't possible.
Thanks. but removing the custom share script is just NO option. I now know where the issue is and will find someone [programmer] who will fix this. do you know any good programmer?
 

Chris D

XenForo developer
Staff member
#12
I'm not asking you to remove it permanently. Just remove it to prove it is that. You don't want to go paying someone to fix it if it turns out it isn't that...
 

Echelon

Active member
#13
I'm not asking you to remove it permanently. Just remove it to prove it is that. You don't want to go paying someone to fix it if it turns out it isn't that...
that's the point....i cannot remove it because im not skilled enough to solve the issues.....im not a programmer...im just a simple guy who wants his forum to work ;-)
 

Tracy Perry

Well-known member
#14
that's the point....i cannot remove it because im not skilled enough to solve the issues.....im not a programmer...im just a simple guy who wants his forum to work ;-)
If it is loaded in a template, just precede it with a <xen:comment> and place a </xen:comment> after it. That should disable it.
 

Echelon

Active member
#15
If it is loaded in a template, just precede it with a <xen:comment> and place a </xen:comment> after it. That should disable it.
this is no solution. the solution is that my custom social buttons as well as my social integration both work. disabling this extremely important buttons is in no way any discussable option
 

Tracy Perry

Well-known member
#16
this is no solution. the solution is that my custom social buttons as well as my social integration both work. disabling this extremely important buttons is in no way any discussable option
Point is... it will allow you to discover for SURE on YOUR CURRENT STYLE if that is the problem. It's not the "solution" but the first step towards confirming that is the problem. If you have no desire to attempt to confirm that is the problem on that style then fixing it will be "difficult".
You specifically stated that
that's the point....i cannot remove it because im not skilled enough to solve the issues.....im not a programmer...im just a simple guy who wants his forum to work ;-)
and I gave you the solution for removing it to see if it was the problem.