• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Design issue Bug - profile news page, new post away after upgrade

Pinn

Active member
#1
When I on the wall page (profile messages page) New Profile Posts | XenForo Community
write a post and then the page
new charge e.g. with F5 of off my posting and not coming back also!
Only when I was in my profile the posting on the page will be shown again!
This is for chrome, Firefox, IE and Safari so all browsers!
All Xenforo are affected versions since there is!
 

Jeremy

Well-known member
#3
The page is intended to show you what it considers new posts, and as there aren't read tracking, it shows you recent posts from other members as you would have seen your own. So this'll most likely be as designed.
 

Pinn

Active member
#5
The page is intended to show you what it considers new posts, and as there aren't read tracking, it shows you recent posts from other members as you would have seen your own. So this'll most likely be as designed.
Why does my posting appear after pushing send and then off when I press F5?
Don't think it should be so.
 

Chris D

XenForo developer
Staff member
#6
Well, I actually think it's down to the page being cached (through the search system).

The replication steps, I believe are:

1) Go to Find New Profile Posts
2) Use the Menu to "Update Your Status"
3) Once posted, the new profile post appears as one might expect.
4) Refresh the page

Because the results on the page are cached, refreshing the page will show you the old list of profile posts, minus the one you just created.

It is as designed, in the sense of that's how the find-new / search system works. Though it's not an ideal situation and likely not one that has a simple solution. (Well, there are simple solutions, but they are also not ideal ;))