1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Broken links after migration

Discussion in 'Troubleshooting and Problems' started by Daniel Bittar, Apr 14, 2013.

  1. Daniel Bittar

    Daniel Bittar Member

    Hi there people!

    I had one XenForo install of the version 1.1.4 in one cPanel account with several other sites. After switching my plan to a reseller plan I created one account with for each site. I migrated XenForo the same way I do with my WordPress sites, consisting of the following steps:

    1) Backup database
    2) Backup files
    3) Restore database
    4) Restore files
    5) Edit config files to use the new database, username and password

    It always worked with WordPress and considering my XenForo install is new (it has only my language, themes and nodes) i believed it would work the same way. However now every link is broken. I cant access any of the nodes, contact or support pages, I cant chafe the theme or the language as it always give the following error:

    Code:
    Not Found
     
    The requested URL /forums/evangelho-no-lar.18/ was not found on this server.
     
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    I have no idea how to fix it. I could reinstall but it would give the work to reedit all the texts I've already entered, recreate the nodes and so on. I wouldn't like this.

    If you wish to see the problem my site is forum.cirandaespirita.com.br. Go there and click any link.

    How can I fix it?

    Thanks a lot,
    Daniel Bittar.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Possible causes of friendly URLs not working (usually manifests as "404 not found" error on forum pages):

    1) The .htaccess file is not in place in your forum directory.

    2) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    RewriteBase /xenforo

    3) Your server doesn't have mod_rewrite installed. Consult with your host about this.

    4) Your server doesn't have AllowOverride enabled:

    http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

    Consult with your host about this.
     
  3. Daniel Bittar

    Daniel Bittar Member

    Hi there, Jake!

    Thank you very much. It was the missing .htaccess file. I just copied it over from the old server and it is working now. Now I have a different problem that I'll post in another thread.

    Thank you again!
     

Share This Page