1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Be wary of Firefox 23.0 & Xenforo 1.1.x

Discussion in 'General XenForo Discussion and Feedback' started by MikeMpls, Aug 16, 2013.

  1. MikeMpls

    MikeMpls Well-Known Member

    I now have at least two (probably more) sites (one on 1.1.2, one on 1.1.3) where I can't do in-line edits. When I click the link to edit a post, the text flashes in the Tiny MCE window & disappears. I have to go to "more options" or open the editor in a new tab/window to edit.

    This started a few minutes ago & immediately after I allowed Firefox to upgrade to 23.0.

    Most unlikely a XenForo bug so not reporting there -- these forums have been running just fine for many, many months.

    Edited to add:

    Also happens on 1.1.4.

    Not happening on my 1.2.x (still beta) sites nor here on "xenforo.com".
     
  2. Mike

    Mike XenForo Developer Staff Member

    1.1.5 disables inline editing in FF to deal with this.
     
  3. MikeMpls

    MikeMpls Well-Known Member

    23.0 is a new release of Firefox, no?

    These sites have been functioning for quite a while (the 1.2 site for ~10 months) in their current configuration, and I never had any such issues with FireFox. The sites worked well (as well as Firefox works :D) with all recent upgrades including 21.0 & 22.0 (except that we avoided 9.0.1 about 1.5 years ago, known to have issues with XenForo).
     
  4. Mike

    Mike XenForo Developer Staff Member

    Yeah, it's a new issue in FF 23, we just caught it in early testing and worked around it in XF 1.1.5 (by disabling the inline editor for FF, which obviously isn't ideal but it was what was feasible for a small bug fix release). It's not an issue in XF 1.2.
     
  5. Arty

    Arty Well-Known Member

    It is, but it was available for months via Aurora release channel so it existed when 1.1.5 was released. Aurora release channel is 2 versions ahead of public stable releases.
     
  6. MikeMpls

    MikeMpls Well-Known Member

    Thanks for the info!

    I'm just warning my members to avoid 23.0 if they use Firefox. The 1.2 upgrades are pending but will take a while.
     
  7. Adam Howard

    Adam Howard Well-Known Member

    Firefox 23 has been out for 1/2 month (August 6). So I wouldn't call it new.

    (Although firefox's auto update took a while to apply for some. You could have downloaded it directly via their website. Ubuntu had it 2 days after its release)
     
  8. Carlos

    Carlos Well-Known Member

    ....It is new. :rolleyes:

    2 weeks is new to me.
     
  9. MikeMpls

    MikeMpls Well-Known Member

    So? Does this mean that one who hasn't yet upgraded should magically be aware of its side effects?

    Now they're trying to tempt me with 23.1 ... :eek:
     
  10. Amaury

    Amaury Well-Known Member

    Indeed. The automatic update for 23.0.1 hadn't rolled out to me until Friday.

    Anyway, for those experiencing this issue, either upgrade to 1.2.0 to resolve it or edit via the advanced editor by clicking More Options on the blank quick editor.
     

Share This Page