• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Banned members aren't getting the proper ban message

imthebest

Formerly Super120
#1
Tested on 1.4.1

When a banned member (be it a temporary or a permanent ban) logins to the forum he gets the following generic error message: do_not_have_permission

So the member doesn't have a way to know if he is banned or not. The only way to see the ban message is when he tries to log out, then he gets the message: you_have_been_banned_for_following_reason_x
 

Chris D

XenForo developer
Staff member
#2
Do you put banned members in a usergroup? Have you set permissions on that usergroup? If so, you're getting the generic error because you've removed their permissions to view parts or all of the forum. This is unnecessary. The banning system takes care, automatically, of any access prevention.

Banned user groups should be used primarily for some sort of styling.
 

Liam W

Well-known member
#3
Tested on 1.4.1

When a banned member (be it a temporary or a permanent ban) logins to the forum he gets the following generic error message: do_not_have_permission

So the member doesn't have a way to know if he is banned or not. The only way to see the ban message is when he tries to log out, then he gets the message: you_have_been_banned_for_following_reason_x
This would occur if you add a banned member to a new usergroup that has no permissions. The lack of permissions overrides the ban check, so they see the no permission message.

If you reset all permissions for your banned usergroup to not set, then they'll see the banned message.

Liam
 

Amaury

Well-known member
#4
Do you put banned members in a usergroup? Have you set permissions on that usergroup? If so, you're getting the generic error because you've removed their permissions to view parts or all of the forum. This is unnecessary. The banning system takes care, automatically, of any access prevention.

Banned user groups should be used primarily for some sort of styling.
This.

Ran into the same issue a while ago myself: https://xenforo.com/community/threads/ban-reason.81056/