1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Avater problem!

Discussion in 'Troubleshooting and Problems' started by Linkzy, Feb 15, 2014.

  1. Linkzy

    Linkzy Member

    Yesterday i Bought my license and today I've installed 1.2.5...

    When i installed everything and once i get into my forums, it seems i cant change my avater for some reason when i upload it, it takes ages to upload!!?

    Please help
  2. Mike

    Mike XenForo Developer Staff Member

    Are there any errors logged in the control panel? What sort of image are you trying to upload?

    Issues like this are generally either a configuration issue (permissions, if you've moved the site) or a hosting issue (unchangeable memory limit, broken GD, etc).
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Check the log for relevant errors:

    Admin CP -> Tools -> Server Error Log

    It might be a broken image library. Try using a different library if one is available:

    Admin CP -> Home -> Options -> Attachments -> Default Image Processor

    I have seen some installations of ImageMagick with major lag time, sometimes causing timeouts.
  4. Linkzy

    Linkzy Member

    Server Error Log its fine...

    ImageMagick PECL Extension
    You must have the imagick PECL extension installed.

  5. Linkzy

    Linkzy Member

    My image is fine... Its jpeg and PNG.... For some reason when i upload a avater it takes soo much time to upload -.-
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    So you are currently using GD? And ImageMagick is not available?

    To use ImageMagick the library must be installed on the server, and the extension for it must be installed in PHP:


    This is a job for your server admin or web host.

    Or you can stick with GD and try upgrading that library to the latest version. This is all assuming it's a problem with your image library which is very plausible.

    As Mike said, it can also be a lack of permissions on the server, but that would normally throw a specific error. Make sure data and internal_data are writable. If you have shell access then try running these commands to recursively set permissions in those directories:

    chmod -R 777 data
    chmod -R 777 internal_data
    You might also try 755 permissions. Depending on how PHP is installed, 755 may still be writable. I have seen some server configurations throw errors with 777.
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Not to get ahead of ourselves, but I am assuming this is not a "normal" wait time considering the size of your image. How big is the image (physical size and dimension)? And how fast is your internet connection?
  8. Linkzy

    Linkzy Member

    My connection is fine guys, i Guess its my hosting? which im using a free host thats why its not working for me?
  9. Mike

    Mike XenForo Developer Staff Member

    Yes, that is very likely to be the issue. Try using a small image.

    Alternatively, if you disable JavaScript in your browser and use the non-JS based uploading system, it may give a much more specific error.
  10. Linkzy

    Linkzy Member

    Used a small image still nothing working...
  11. Mike

    Mike XenForo Developer Staff Member

    I suspect this is down to your host. I would strongly recommend against any free host. They are likely limiting the server fairly heavily.

    If you can disable JS in your browser, can you upload an avatar? What message do you get?
  12. Linkzy

    Linkzy Member

    Nothing, but i want everything to run smooth... so my members they can do upload avaters at any time without me doing anything!

    I remember a friend of mines having the same problem I have no idea how he fixed it, He also was on freehost

Share This Page