1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Avatars not showing up in post

Discussion in 'XenForo Questions and Support' started by Steverd, Jun 13, 2014.

  1. Steverd

    Steverd Member

    New user avatars are not showing up on their home page on when they post.
    If you see the attached image, their avatar is there when I click on it, otherwise not showing up.
    So I checked my Attachments and Avatar folders they have perm at 777, but I did notice that ALL of the NEW avatars have 644 or 666.
    I just noticed that ALL of the index.html files in the avatar/l & avatar/m folders are perm 666 or 644

    Should I go ahead and change to 777?
    If this is the problem, when the avatars start showing up automatically or do I need to rebuild the index or DB or something?

    Thank you!
     

    Attached Files:

  2. Brogan

    Brogan XenForo Moderator Staff Member

    You should recursively chmod the /data and /internal_data directories to 0777.
     
  3. Steverd

    Steverd Member

    Still not working, so I looked again all everything that I changed to 777 this morning is back to Perm 644 or 666

    WHAT is this? Should I contact my host? Maybe some server settings???
     
  4. Mike

    Mike XenForo Developer Staff Member

    Those permissions are generally fine. The system will usually figure out the correct setup to use.

    I'm not seeing any broken avatars on your forum. Can you direct me to where you see broken avatars?
     
  5. Steverd

    Steverd Member

    Here on post: Nickmanes, Doggie Jail Rescue and Hi Everyone, the avatar is missing on all three
    http://www.toydogforums.com/index.php?find-new/111970/posts

    If you click any of those like this one, the avatar is not showing up again.
    http://www.toydogforums.com/index.php?threads/nicknames.932/

    If I right click in the box it shows '404' Not Found

    Tried in Firefox and Chrome - BOTH give the same results.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

  7. Steverd

    Steverd Member

    I noticed on these files the Owner is not the same of the other files.
    I tried to change the Ownership with WinSCP and again get an error
    Permission denied.
    Error code: 3
    Error message from server: Permission denied


    So I can not change the file permissions on any of the files that show 'nobody' as owner
    Then I can also not change the ownership. I'm hosting on a Mike Edge server, I hope he is around here
    to help fix this.
     
  8. Steverd

    Steverd Member

    No, I moved to a Mike Edge server back in April, but nothing since.
    The Small and Medium versions of 195.jpg are MISSING from the those above folder. (why?) I didn't remove them

    ALSO new users 191.jpg, 193.jpg are missing from the small and medium folder.

    Also I just deleted and updated a slight different avatar for myself, it shows up in all three folders: S,M,L but has a file permission of 666
    Is that OK?

    Thanks
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    The user you are logging in to FTP with doesn't have permission to change the file ownership.

    You will need to log in with a user which does.

    The files have been removed from the server for some reason.
    If there is a server log it may shed some light. Contact your host.

    Those members will have to add new avatars.

    Yes, 666 is fine.
     
  10. Steverd

    Steverd Member

    The only thing the server logs how is:
    2014-06-15 05:34:18.898 [INFO] [67.161.100.42:50644-1#APVH_toydogforums.com] File not found [/home/toydogfo/public_html/404.shtml]
    2014-06-15 05:34:18.898 [INFO] [67.161.100.42:50644-1#APVH_toydogforums.com] File not found [/home/toydogfo/public_html/data/avatars/s/0/195.jpg]
    2014-06-15 05:34:17.606 [INFO] [67.161.100.42:50644-0#APVH_toydogforums.com] File not found [/home/toydogfo/public_html/404.shtml]
    2014-06-15 05:34:17.606 [INFO] [67.161.100.42:50644-0#APVH_toydogforums.com] File not found [/home/toydogfo/public_html/data/avatars/m/0/195.jpg]

    For about 300 times.
    Hey how come there is not a 404.shtml file included with Xenforo?
     
  11. Steverd

    Steverd Member

    So I logged in as the user. I saved her avatar, deleted the current one and then upload the same one again!.
    As it should there is a Small, Med and Large 195.jpg in the file correct folders now.
     
  12. Mike

    Mike XenForo Developer Staff Member

    That 404 handler is something specific to your server. We actually generally return it to the default value (but LiteSpeed doesn't do that, for example).

    It's hard to say why it didn't work before then. Normally, that would imply that the permissions were wrong as covered before, but specifically on the s/m folders (not the l folder). If an error like this happens again, it might be worth checking with your host - given that he knows XF and his server config, he should know what to check for (what would be expected based on his config).
     
  13. Tracy Perry

    Tracy Perry Well-Known Member

    Probably owned by nobody:nogroup - On a Debian setup that is the typical OpenLiteSpeed ownership settings of OLS (and maybe LiteSpeed also, not going to spend the money to check since I'm back to nginx now and it's owner is www-data:www-data).

    When I played with OLS, I had to make sure that all the forum files were owned by nobody:nogroup to get the add-on installer to work correctly (otherwise it had no permissions to install any updates if I had manually uploaded them since they were then owned by me). I got around that another way, but on a shared hosting it would be difficult to implement.

    This is something that you will need to contact @Mike Edge about - it shouldn't be that difficult for him to resolve.
     

Share This Page