• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Avatar Gallery 0.1b

No permission to download

Naatan

Well-known member
#1
Naatan submitted a new resource:

AvatarGallery (version 0.1) - Adds an avatar gallery to the choose avatar page

This is just a bare basics addon that adds an avatar gallery to the page where you choose your avatar.

Installation is the same as with any other addon. Once installed be sure to check the Options page to enable the gallery and change the path where the gallery looks for avatar images. And of course copy some images to the avatars folder configured in the options screen.
Read more about this resource...
 

DRE

Well-known member
#4
This add-on either doesn't work or is broken. When you click on 'Avatar' it says there is an error in the javascript.
 

Digital Doctor

Well-known member
#6
+Like.
People have been asking for this for a long time !

To make this easier to find, please change the name from AvatarGallery 0.1 to Avatar Gallery 0.1
Anyone title searching resources for Avatar will not find your Addon.
 

DRE

Well-known member
#7
Would you please consider changing your read me's to files most normal people can actually open up? wtf is a .md extension? How do I open this up?
 

DRE

Well-known member
#11
This addon does not use any javascript, so that sounds a bit fishy. What browser are you using? And what error are you getting?
Firefox 10.0.1

The following error occurred

The server responded with an error. The error message is in the JavaScript console.
 

Naatan

Well-known member
#14
+Like.
People have been asking for this for a long time !

To make this easier to find, please change the name from AvatarGallery 0.1 to Avatar Gallery 0.1
Anyone title searching resources for Avatar will not find your Addon.
Thanks for the suggestion, made the change.
Would you please consider changing your read me's to files most normal people can actually open up? wtf is a .md extension? How do I open this up?
.md is markdown which is used by github, where this project is managed. The readme is just an artifact of zipping it there to upload it here, you do not need to read it as everything is already explained here.

Great job :) does this support categories at all?
No, it's just a bare basics addon.. It's also open-source so you're free to modify it in any way you like.
Firefox 10.0.1

The following error occurred

The server responded with an error. The error message is in the JavaScript console.
Please check for what error you are getting using the following steps: http://www.cmsmarket.com/resources/dev-corner/92-how-to-check-for-javascript-errors

I highly doubt it's this addon causing the error, rather you likely have a different addon installed that's conflicting with this one. I'll need to know the error in order to remove the conflict though.
Where are the avatars?!
This addon only gives you the ability to use avatar gallery's, you still have to add the actual avatars yourself.
 

DRE

Well-known member
#15
Thanks for the suggestion, made the change.

.md is markdown which is used by github, where this project is managed. The readme is just an artifact of zipping it there to upload it here, you do not need to read it as everything is already explained here.



No, it's just a bare basics addon.. It's also open-source so you're free to modify it in any way you like.

Please check for what error you are getting using the following steps: http://www.cmsmarket.com/resources/dev-corner/92-how-to-check-for-javascript-errors

I highly doubt it's this addon causing the error, rather you likely have a different addon installed that's conflicting with this one. I'll need to know the error in order to remove the conflict though.

This addon only gives you the ability to use avatar gallery's, you still have to add the actual avatars yourself.
OverlayLoader for account/avatar
PHP
Fatal error: Call to undefined function exif_imagetype() in /home/user/public_html/library/AvatarGallery/AvatarGallery.php on line 24
 

Naatan

Well-known member
#18
OverlayLoader for account/avatar
PHP
Fatal error: Call to undefined function exif_imagetype() in /home/user/public_html/library/AvatarGallery/AvatarGallery.php on line 24
Thanks, that's what I needed. I've posted an update that removes the exif dependency, although it's a pretty standard PHP extension to have enabled.
 

Naatan

Well-known member
#20
I'm on a shared host.
Yeah I figured, and a lot of people will be in the same situation, which is why I removed the dependency. Even for shared hosts it's a pretty standard extension though. Also it seems yours is still running PHP 5.2 (based on your problem with the Ajax Polling addon), it'll serve you fine for now, but if they don't update soon (within a year or so) you are likely going to run into problems like this more often, depending on how much PHP software you use.