1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed auto embed video problem

Discussion in 'Resolved Bug Reports' started by D.O.A., Oct 7, 2011.

  1. D.O.A.

    D.O.A. Well-Known Member

    When I use/paste a URL that is clickable, the video does not embed for me, in the wysiwyg editor.

    1) http://www.youtube.com/watch?v=tNcZyDSM6GI < clickable (url tags), wont embed.

    2) < URL tags removed and it works.

    The posted link is automatically going to use URL tags most times (almost always) if you cut/paste into the wysiwyg editor, so my members will not realize they need to just post the URL as a plain text in order for it to work. For ease of use it seems url's should be converted too, unless the option for having a url appear with the video is enabled, of course. Maybe not a bug, but it seems to be, if you just expect video to embed by using the link you copied in.
     
    Digital Doctor, robdog and Marcus like this.
  2. DSF

    DSF Well-Known Member

    It works perfect. Her a screendump

    1.png
     
  3. D.O.A.

    D.O.A. Well-Known Member

    http://www.youtube.com/watch?v=tNcZyDSM6GI

    I'm talking about the cut/paste auto [ url ] wrapped links in the wysiwyg editor, as I just posted above. I didn't work. This is what my users post 99% of the time. Unless its a chrome bug what I just posted didn't embed.
     
  4. ragtek

    ragtek Guest

    If you post a video in via[url]http://www.youtube.com/watch?v=tNcZyDSM6GI[/url] it WON'T be rewriten!
    that's AFAIK as designed (don't want to search for the post in the hys thread:p )
     
  5. Cooper

    Cooper Active Member

    Same on my forum. Embeds automatically in basic editor but not in WYSIWYG editor.
     
  6. D.O.A.

    D.O.A. Well-Known Member

    Well as designed it's counter intuitive, the link is crafted by the editor, my users expect it to just embed.

    "just paste the video link you copied in the wysiwyg editor, then go to the plain text editor and remove the URL tags that were automatically added. your video will now embed."

    How is that any simpler/quicker then using the media button?

    People cut the browser link for youtube vids rather then go to the embed options for the link, so
    the URL tags are added by the editor, no matter what.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  8. Divvens

    Divvens Well-Known Member

    Its due to the editor turning copy pasted link directly to hyperlinks. It's annoying :p
     
    D.O.A. likes this.
  9. D.O.A.

    D.O.A. Well-Known Member

    well hopefully hyperlinks can be added, if I want to use video hyperlinks in posts I can turn the embed option off or use the new option to display the video and the link. Having only plain text embed is annoying and not what people (aka: your users) expect and not what the editor delivers when you paste in a link.

    Kier, you're a fan of options, how about another one? convert hyperlinks :D
     
    CapnLuffy likes this.
  10. robdog

    robdog Well-Known Member

    Just ran into this on my sites. Definitely something that my sites would use since a lot of people copy and paste from the URL box. Hoping this is getting done in B4! :p
     
  11. Mike

    Mike XenForo Developer Staff Member

    This has been tweaked.
     
    Fuhrmann and Andy.N like this.
  12. Andy.N

    Andy.N Well-Known Member

    Can't wait for beta 4
     

Share This Page