• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Attachments Rotated

#1
Hi all,

I have a problem in my forum where some attachments (images) are displaying the wrong way around.

When you load the attachment via the attachments URL it is the correct rotation but when you load it in a post it displays upside down or rotated incorrectly.

This is completely random and was wondering if there is any reason or some where I could look to solve this riddle?

Things I have done so far -

1) Check in the admin area to view the attachment and it appears the correction rotation

2) Right clicked on the image and opened in new tab and image is correct rotation. But in the thread its rotated 90" degress.

3) Tried default style as a I use a custom style no change

Help!!!
 

AndyB

Well-known member
#7
I've been telling my members to take the picture with their iPhone with the home button on the right, that way the orientation is correct when displayed in the thread.
 
#8
I've been telling my members to take the picture with their iPhone with the home button on the right, that way the orientation is correct when displayed in the thread.
Sorry don't have an iphone so you are saying if the home button is on the right then the picture comes out correctly?

What about ipad?
 

Mike

XenForo developer
Staff member
#12
Current versions automatically do rotation based on EXIF data in the image. That is, provided the PHP EXIF extension is installed on the server.