1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Attachments Rotated

Discussion in 'Troubleshooting and Problems' started by lostincable, Apr 7, 2013.

  1. lostincable

    lostincable Active Member

    Hi all,

    I have a problem in my forum where some attachments (images) are displaying the wrong way around.

    When you load the attachment via the attachments URL it is the correct rotation but when you load it in a post it displays upside down or rotated incorrectly.

    This is completely random and was wondering if there is any reason or some where I could look to solve this riddle?

    Things I have done so far -

    1) Check in the admin area to view the attachment and it appears the correction rotation

    2) Right clicked on the image and opened in new tab and image is correct rotation. But in the thread its rotated 90" degress.

    3) Tried default style as a I use a custom style no change

  2. AndyB

    AndyB Well-Known Member

    I suspect this is an issue with images uploaded with an Apple mobile device (iPad or iPhone).
  3. lostincable

    lostincable Active Member

    Interesting, care to elaborate?
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. AndyB

    AndyB Well-Known Member

    Brogan's link post #4 explains the issue.

    It would be a great feature if xF would look at the EXIF data after the image is uploaded and auto-rotate it to the correct orientation.
  6. lostincable

    lostincable Active Member

    I think it is,

    Just checked the exif data and it says

    Rotated 90 Degrees
    However when viewing the attachment full screen via the below URL it is the correct rotation -


    But when viewing it in a thread it is the wrong rotation?
  7. AndyB

    AndyB Well-Known Member

    I've been telling my members to take the picture with their iPhone with the home button on the right, that way the orientation is correct when displayed in the thread.
  8. lostincable

    lostincable Active Member

    Sorry don't have an iphone so you are saying if the home button is on the right then the picture comes out correctly?

    What about ipad?
  9. AndyB

    AndyB Well-Known Member


    Same issue with iPad. Ask the member to take a picture with the home button on the right and the picture will be in the correct orientation.
  10. Shelley

    Shelley Well-Known Member

    Ernest @ simcitytalk.com was experiencing this last night when he uploaded some photos with his apple device.
  11. StonePilot

    StonePilot Member

    I'm getting this issue with pics taken on my android phone. Would be nice if we could rotate attachment images if needed.
  12. Mike

    Mike XenForo Developer Staff Member

    Current versions automatically do rotation based on EXIF data in the image. That is, provided the PHP EXIF extension is installed on the server.

Share This Page