Resource icon

Attachment Viewer 0.9.1

No permission to download

xfrocks

Well-known member
Attachments from soft deleted posts are showing up. Is there a way to not have these posts and attachments show up in the attachment viewer?
IIRC, it shows attachment from posts that you have permissions to view. So if you are an admin/mod, you will see those attachments.
 

0ptima

Well-known member
IIRC, it shows attachment from posts that you have permissions to view. So if you are an admin/mod, you will see those attachments.

A user will see the link in this addon and when clicked, get a "The requested thread could not be found." error.
 

0ptima

Well-known member
Can you take a screenshot?

Here is my test user
upload_2014-9-21_20-26-17.png

Test User created 2 threads with an attachment in each thread. Test user deletes a thread. This is the view from the admin account.
upload_2014-9-21_20-26-46.png

Test user sees all the attachments, including the attachments from the deleted thread
upload_2014-9-21_20-28-35.png

Clicking on the deleted attachment produces the following

upload_2014-9-21_20-29-49.png
Clicking on the deleted post produces the following
upload_2014-9-21_20-31-1.png
 

MRaburn

Active member
I have updated the resource main page to reflect version it works with.

As Otto stated, it does work with no issues.
 

otto

Well-known member
Hello,

see you a chance to make a option, so a user, in specific group, can download all there attachments in one click?
 

Axel B

Well-known member
Hi there! First of all I really love this addon! Excellent work!
Hopefully a small request, but is it possible to add the BBCode of the attachment in the overview? That would make it easier for people to reuse their attachments.
I am willing to pay for the work done :)
 

Joeychgo

Well-known member
@xfrocks

When I have this set to Any Forum --- I get "There is no attachments to display"

But when I go to specific forums and filter, then I get attachments listed.

Why? And how do I fix this?

Also, I have the slow query logger installed (https://xenforo.com/community/resources/slow-query-logger.5174) and I get slow queries all the time from this addon. The error looks like this:

Exception: Slow query detected: 1.2181 seconds, /mopar/attachments/mine - library/SV/SlowQueryLogger/Profiler.php:51

#0 /home/forabodi/public_html/mopar/library/Zend/Db/Statement.php(319): SV_SlowQueryLogger_Profiler->queryEnd(4)
#1 /home/forabodi/public_html/mopar/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/forabodi/public_html/mopar/library/Zend/Db/Adapter/Abstract.php(825): Zend_Db_Adapter_Abstract->query('\r\n\t\t\t\tSELECT CO...', Array)
#3 /home/forabodi/public_html/mopar/library/XenForo/Model/Attachment.php(407): Zend_Db_Adapter_Abstract->fetchOne('\r\n\t\t\t\tSELECT CO...')
#4 /home/forabodi/public_html/mopar/library/AttachmentViewer/XenForo/ControllerPublic/Attachment.php(60): XenForo_Model_Attachment->countAttachments(Array, Array)
#5 /home/forabodi/public_html/mopar/library/AttachmentViewer/XenForo/ControllerPublic/Attachment.php(7): AttachmentViewer_XenForo_ControllerPublic_Attachment->AttachmentViewer_actionMyAttachments()
#6 /home/forabodi/public_html/mopar/library/XenForo/FrontController.php(351): AttachmentViewer_XenForo_ControllerPublic_Attachment->actionMine()
#7 /home/forabodi/public_html/mopar/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /home/forabodi/public_html/mopar/index.php(13): XenForo_FrontController->run()
#9 {main}


array(3) {
["url"] => string(52) "http://www.forabodiesonly.com/mopar/attachments/mine"
["_GET"] => array(0) {
}
["_POST"] => array(2) {
["filters"] => array(1) {
["forum"] => string(0) ""
}
["_xfToken"] => string(8) "********"
}
}
 

ProCom

Well-known member
This is a brilliant addon!

Regarding this request below... I'm SHOCKED that XF doesnt' do this by default and would GLADLY pay for an updated addon that does this!

Would be cool if this could be modded so that when a user is posting a reply/new thread,they are able to choose from their attachments to put into the post. Would save a lot of time on my forum!

Ideally, the insert image pop modal would look something like this:
(shows the 5 most recent images and a "more" link)

upload_2016-11-16_11-19-12.png
 

ProCom

Well-known member
We unfortunately had to uninstall this addon because it was showing the wrong uploads to the wrong users. We haven't been able to dig into it, but hopefully there's a fix / solution. (I'm on XenForo 1.5.13)
 
Top