• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Are these XF image proxy related URLs?

Mike

XenForo developer
Staff member
#3
These aren't valid URLs, in that they have multiple levels of encoding (and aren't URLs XF would generate). Because they aren't valid, they can't even be detected as image proxy URLs.
 
#4
@Mike -

One quick question: what if I change the key in the admin?

"Image and Link Proxy Secret Key - If you find that links are being accessed via third-party sites, you can change this secret key to expire these links. All links stored on the forum will be automatically updated to use the new secret key."

Here's why I think maybe these are not originating at my forum, but are being accessed from a third party site:

 

Mike

XenForo developer
Staff member
#5
Changing that value won't help here as the code isn't even getting there.

I'm changing the response code in this case to 400 (for the next release), which indicates a bad request and that the server can't respond due to a client error (in this case, a logic/malformed syntax error). This may still be listed in webmaster tools, but the alternative is returning a 200 which would indicate that the page is valid, which is clearly not correct.
 
#6
I'm changing the response code in this case to 400 (for the next release), which indicates a bad request and that the server can't respond due to a client error
Great idea. I appreciate you thinking of doing this. The real question is whether 400's are also counted against the site ranking-wise, like 500's can sometimes be. If 400's are safe then its fine to return that. But if they're exactly like 500's in googles eyes it might make no difference. Should I ask around?
 
#7
Okay so apparently 400 errors are a referred to as "400 level" errors and are part of a group of errors, among which are 400, 410 and 404.

All of which are considered somewhat inert to Google, rankingwise.

I hope that is correct. I just googled a bit.
 
#8
Initially i thought if we deleted the broken images on our forums, this would fix the problem.

But:

Actually this has nothing to do with them being broken or not. The external link which is pointing to these images on our site, is malformed.

So broken or not, the problem is the external link. This means that the best we can do in the short term is to delete the image.


This means when google goes to look for it, its going to serve a 404 instead of a 500 most likely. Im hoping.

----------------------------

EDIT 2: When I deleted the image from our forums, it still serves the 500 on our forum and says malformed proxy ........................... :(

So there's literally nothing we can do.

Am I understanding this correctly @Mike ?
 
Last edited:

Mike

XenForo developer
Staff member
#9
These are malformed links. There's nothing you can do within XF to prevent the code from responding this way. If you are desperate to block them, you'll need to do it at the web server level.