1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Anyway to fix Thread IDs?

Discussion in 'Troubleshooting and Problems' started by Cambion, Aug 16, 2014.

  1. Cambion

    Cambion Well-Known Member

    So it has been about 2 weeks since I converted to XF from IPB and the redirects appear to be working, however I noticed something interesting.

    Instead of it redirecting to the correct thread(Example: If i posted a Book review and i click the IPB version of my site link) i'd expect it to redirect me back to the XF version of the same link.

    Instead it redirects me to a corresponding thread ID that has nothing to do with the book review. It's not too big a deal really I suppose(Especially since XF is already causing new links to rank high and faster than they did with IPB) but i was wondering is it possible so that the correct link responds to the thread.

    I suppose i worry that if someone wants to read a review of "The Giver" and it redirects them to a discussion about my little pony lol
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    How have you implemented redirects?

    If you are using the scripts it should redirect to the correct thread.
     
  3. AndyB

    AndyB Well-Known Member

    Please provide a IPB link example and the correct XF link that it should go to.
     
  4. Cambion

    Cambion Well-Known Member

    Edit: I figured out the issue Partially.
    It wasn't an IPB link like I thought it was....it was a link from when we first used XF last year. But the thread now redirects back to the wrong thread

    Xenforo(2013) link aka the original Version:
    http://chaosreads.com/threads/frostbite-richelle-mead-is-this-any-good.6094/

    Xenforo 2014 Version(where it redirects to now):
    http://chaosreads.com/threads/just-a-heads-up-about-tagging.6094/

    The Correct Link:
    http://chaosreads.com/threads/frostbite-richelle-mead-is-this-any-good.5977/

    I still have issues with the IPB links not redirecting.....
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    So the question remains, how have you implemented the IPB redirects?
    What is an IPB URL and the corresponding XF URL?

    For the old/superseded XF install, you will have to put some custom rewrites in place for it.
     
  6. Cambion

    Cambion Well-Known Member

    Here is an IPB link:
    http://chaosreads.com/topic/8118-guardianproxy-2-by-alex-londonreview/


    Here is it's Corresponding Xenforo Link:
    http://chaosreads.com/threads/guardian-proxy-2-by-alex-london-review.8118/

    I (thought) i followed the directions well enough in Mike's Script.....But i must be doing something wrong. I just don't know what really.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    So your XF installation is in the same directory as your IPB installation and you have added the .htaccess, 301config and ips2xf files to the IPB/XF directory?
     
  8. Mike

    Mike XenForo Developer Staff Member

    You submitted a ticket about this about a week ago and never responded to my last message (asking for access details to look into it).
     
    Brogan likes this.
  9. Cambion

    Cambion Well-Known Member

    Sorry about that(Got Side-tracked ).
    I'll respond to that ticket now...I forgot i had even opened a ticket tbh!
     

Share This Page