• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Anyone got any ideas about this error

gavpeds

Active member
#1
Code:
Server Error Log
Error Info
ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages: error:140D00CF:SSL routines:SSL_write:protocol is shutdown - library/Zend/Mail/Protocol/Abstract.php:324
Generated By: Unknown Account, Yesterday at 8:44 PM
Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(2, 'fwrite(): SSL o...', '/home/window/pu...', 324, Array)
#1 /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php(324): fwrite(Resource id #9, 'QUIT\r\n')
#2 /home/window/public_html/library/Zend/Mail/Protocol/Smtp.php(385): Zend_Mail_Protocol_Abstract->_send('QUIT')
#3 /home/window/public_html/library/Zend/Mail/Transport/Smtp.php(183): Zend_Mail_Protocol_Smtp->quit()
#4 /home/window/public_html/library/XenForo/Model/MailQueue.php(87): Zend_Mail_Transport_Smtp->resetConnection()
#5 /home/window/public_html/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.9999971389771)
#6 /home/window/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_MailQueue->execute(Array, Array, 7.9999971389771, '')
#7 /home/window/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999971389771, '', false)
#8 /home/window/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#9 /home/window/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#10 {main}
Request State
array(3) {
  ["url"] => string(46) "http://domain/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(47) "/threads/culling-needed-but-still-sad-no.22243/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"
  }
}
Seems it could be something to do with my smtp email setup but only just started getting this error, has been fine until very recently.
 

Mike

XenForo developer
Staff member
#2
Is this a one off or is it happening consistently?

It sounds like the server has already closed the connection (though you are trying to end the connection there).
 

Mike

XenForo developer
Staff member
#4
If it's not that frequent, you can likely disregard it. However, it does sound like the connection has already been closed here, so this may indicate a connectivity issue with the SMTP server or the SMTP server is forcibly closing the connection before the mail has been completely sent.
 

gavpeds

Active member
#5
Still getting these errors.
Code:
[Mon Nov 28 19:59:19.688601 2016] [:error] [pid 14716] [client 94.191.188.205:64836] PHP Fatal error:  Uncaught ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages:\nerror:140D00CF:SSL routines:SSL_write:protocol is shutdown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php:324\nStack trace:\n#0 [internal function]: XenForo_Application::handlePhpError(2, 'fwrite(): SSL o...', '/home/window/pu...', 324, Array)\n#1 /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php(324): fwrite(Resource id #9, 'QUIT\\r\\n')\n#2 /home/window/public_html/library/Zend/Mail/Protocol/Smtp.php(385): Zend_Mail_Protocol_Abstract->_send('QUIT')\n#3 /home/window/public_html/library/Zend/Mail/Transport/Smtp.php(144): Zend_Mail_Protocol_Smtp->quit()\n#4 [internal function]: Zend_Mail_Transport_Smtp->__destruct()\n#5 {main}\n  thrown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php on line 324, referer: https://windowcleaningforums.co.uk/threads/what-do-you-do-out-of-work.22920/
[Mon Nov 28 19:43:17.714544 2016] [:error] [pid 13616] [client 146.198.102.249:58689] PHP Fatal error:  Uncaught ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages:\nerror:140D00CF:SSL routines:SSL_write:protocol is shutdown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php:324\nStack trace:\n#0 [internal function]: XenForo_Application::handlePhpError(2, 'fwrite(): SSL o...', '/home/window/pu...', 324, Array)\n#1 /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php(324): fwrite(Resource id #9, 'QUIT\\r\\n')\n#2 /home/window/public_html/library/Zend/Mail/Protocol/Smtp.php(385): Zend_Mail_Protocol_Abstract->_send('QUIT')\n#3 /home/window/public_html/library/Zend/Mail/Transport/Smtp.php(144): Zend_Mail_Protocol_Smtp->quit()\n#4 [internal function]: Zend_Mail_Transport_Smtp->__destruct()\n#5 {main}\n  thrown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php on line 324, referer: https://windowcleaningforums.co.uk/threads/what-do-you-do-out-of-work.22920/page-4
[Mon Nov 28 19:11:38.730143 2016] [:error] [pid 11717] [client 94.194.14.83:50047] PHP Fatal error:  Uncaught ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages:\nerror:140D00CF:SSL routines:SSL_write:protocol is shutdown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php:324\nStack trace:\n#0 [internal function]: XenForo_Application::handlePhpError(2, 'fwrite(): SSL o...', '/home/window/pu...', 324, Array)\n#1 /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php(324): fwrite(Resource id #9, 'QUIT\\r\\n')\n#2 /home/window/public_html/library/Zend/Mail/Protocol/Smtp.php(385): Zend_Mail_Protocol_Abstract->_send('QUIT')\n#3 /home/window/public_html/library/Zend/Mail/Transport/Smtp.php(144): Zend_Mail_Protocol_Smtp->quit()\n#4 [internal function]: Zend_Mail_Transport_Smtp->__destruct()\n#5 {main}\n  thrown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php on line 324, referer: https://windowcleaningforums.co.uk/threads/how-much-should-i-charge-for-gutter-cleaning.11842/
[Mon Nov 28 19:07:59.636812 2016] [:error] [pid 11317] [client 81.156.138.123:55019] PHP Fatal error:  Uncaught ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages:\nerror:140D00CF:SSL routines:SSL_write:protocol is shutdown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php:324\nStack trace:\n#0 [internal function]: XenForo_Application::handlePhpError(2, 'fwrite(): SSL o...', '/home/window/pu...', 324, Array)\n#1 /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php(324): fwrite(Resource id #9, 'QUIT\\r\\n')\n#2 /home/window/public_html/library/Zend/Mail/Protocol/Smtp.php(385): Zend_Mail_Protocol_Abstract->_send('QUIT')\n#3 /home/window/public_html/library/Zend/Mail/Transport/Smtp.php(144): Zend_Mail_Protocol_Smtp->quit()\n#4 [internal function]: Zend_Mail_Transport_Smtp->__destruct()\n#5 {main}\n  thrown in /home/window/public_html/library/Zend/Mail/Protocol/Abstract.php on line 324, referer: https://windowcleaningforums.co.uk/find-new/716236/posts
 

gavpeds

Active member
#6
Is there anyway to get a log of SMTP conversations between our xenforo install and SparkPost which is the SMTP service we are using. Maybe this would help show what errors we are hitting.