XF 1.1 animated avatars do not work when resized even with imagick

I have imagemagick enabled and am running XF 1.1.5. When I upload an animated gif for an avatar, the resized version is not animated. Furthermore, it is being saved as a .jpg.

This thread http://xenforo.com/community/threads/imagemagick-imagick-pecl-extension-animated-avatars-not-working.17660/page-4 seems to suggest this was a bug that was fixed. And there are a ton of other threads on this issue but I couldn't seem to get any useful advice out of them.

Ubuntu 12.04.2 LTS, php 5.3.10-1, imagick 3.1.0RC1
 

Jeremy

Well-known member
What image formats are supported on your server? Can be found under PHP info (admin.php?tools/phpinfo) and under the ImageMagick supported formats.
 
3FR, A, AAI, AI, ART, ARW, AVI, AVS, B, BGR, BGRA, BMP, BMP2, BMP3, BRF, C, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FITS, FRACTAL, FTS, G, G3, GIF, GIF87, GRADIENT, GRAY, GROUP4, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, ICB, ICO, ICON, INFO, INLINE, IPL, ISOBRL, J2C, JNG, JP2, JPC, JPEG, JPG, JPX, K, K25, KDC, LABEL, M, M2V, M4V, MAC, MAP, MAT, MATTE, MIFF, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MTV, MVG, NEF, NULL, O, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG24, PNG32, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, R, RADIAL-GRADIENT, RAF, RAS, RGB, RGBA, RGBO, RLA, RLE, SCR, SCT, SFW, SGI, SHTML, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UIL, UYVY, VDA, VICAR, VID, VIFF, VST, WBMP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, Y, YCbCr, YCbCrA, YUV
 

Jeremy

Well-known member
Hm. It seems like you have support for all the file types in there. What is the link to an animated avatar that isn't working (ie, is it becoming a .gif)?
 

CTXMedia

Formerly CyclingTribe
Can you upload the file you're trying to use as the avatar - that way others can try it and test whether it's a problem with the file itself.
 

Steve F

Well-known member
Works on my installs.

Running

imagick module - 3.0.1 (Not RC it wouldnt work for me )
ImageMagick 6.5.4-7
 

Tracy Perry

Well-known member
downgrading to 3.0.1 fixes the problem. everyone running ubuntu 12.04 LTS will have this problem, might help to have a guide somewhere.
I'm running Debian 7.0 on my servers and using 3.1.0RC2 of imagick module and ImageMagick 6.7.7-10.
Only time that happened to me was when I had GD designated in the Attachments section in ACP. Once I clicked on ImageMagick PECL Extension and saved it I could use the supplied image anywhere as animated.
I'm pretty sure that you can use dot.deb with Ubuntu - and I think you will get the latest from there.
 
Top