1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Analyzing permissions versus testing

Discussion in 'XenForo Questions and Support' started by zylstra, Oct 8, 2015.

  1. zylstra

    zylstra Member

    I analyze a user's permission to view a node, and the answer is yes. Then I test that user's permission and cannot see the node. Why is that?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. zylstra

    zylstra Member

    I don't see that any of those caveats pertain to my testing. Which one in particular are you referring to?

    My end goal is to allow users to view my forums, which currently they cannot do.
     
  4. Mike

    Mike XenForo Developer Staff Member

    How have you setup your permissions in this instance?
     
  5. zylstra

    zylstra Member

    Possibly pertinent info: This forum was created with the vB big board importer. I did run the User Cache update. Could this have a bearing on it if I didn't run it?

    Is this the information you are looking for?

    snap.png
     
    Last edited: Oct 8, 2015
  6. zylstra

    zylstra Member

    Sadik B helped me out. I toggled/saved a usergroup and node permission back and forth, and apparently that resets the permissions to the stated values. Could you elaborate on this process? Could I have toggled just the usergroup permission?
     
    Last edited: Oct 9, 2015
  7. Mike

    Mike XenForo Developer Staff Member

    This is likely very relevant, as it may not have built all of the permission combinations as expected. What you did forced a rebuild of this information.
     
    zylstra likes this.
  8. zylstra

    zylstra Member

    @Mike, creating a button to rebuild permissions on the Tools -> Rebuild Caches admin page would be intuitive - perhaps both clean up and rebuild with one button.
     

Share This Page