• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Analyzing permissions versus testing

#1
I analyze a user's permission to view a node, and the answer is yes. Then I test that user's permission and cannot see the node. Why is that?
 
#3
I don't see that any of those caveats pertain to my testing. Which one in particular are you referring to?

My end goal is to allow users to view my forums, which currently they cannot do.
 
#5
Possibly pertinent info: This forum was created with the vB big board importer. I did run the User Cache update. Could this have a bearing on it if I didn't run it?

Is this the information you are looking for?

snap.png
 
Last edited:
#6
Sadik B helped me out. I toggled/saved a usergroup and node permission back and forth, and apparently that resets the permissions to the stated values. Could you elaborate on this process? Could I have toggled just the usergroup permission?
 
Last edited:

Mike

XenForo developer
Staff member
#7
Possibly pertinent info: This forum was created with the vB big board importer. I did run the User Cache update. Could this have a bearing on it if I didn't run it?
This is likely very relevant, as it may not have built all of the permission combinations as expected. What you did forced a rebuild of this information.
 
#8
@Mike, creating a button to rebuild permissions on the Tools -> Rebuild Caches admin page would be intuitive - perhaps both clean up and rebuild with one button.