1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 An unexpected error occurred. Please try again later.

Discussion in 'XenForo Questions and Support' started by Zaragan, Jul 4, 2014.

  1. Zaragan

    Zaragan Member

    Im getting this error and i cant modify my MySQL's table_definition_cache and table_open_cache...

    Any idea to solve this pls??

    Thank you!!
     
  2. Mike

    Mike XenForo Developer Staff Member

    Looking at your forum, it's caused by your host (1and1) applying a broken update to their servers. (It has essentially disabled prepared statements entirely.) We have had a number of reports of this today.

    Only your host can fix this. We have been told that switching to PHP 5.5 resolves the issue.
     
  3. Zaragan

    Zaragan Member

    I call to my host but they say "we cant do anything, buy this and this and its solved" bla bla bla (i guess only the host can update the php version, true? if not, please, explain me :p)

    Anyway, ty for your quickly answer!
     
  4. Mike

    Mike XenForo Developer Staff Member

    Correct and it appears that them doing that is exactly what broke it.

    If you want to talk to your host again, it's quite important that they understand that this is affecting a number of their customers and it all happened within a day. Ideally, they should be able to look at their own support requests and see this because we've directed every person that reported this to us back to them.

    Looking at PHP info data, it's clear they recently recompiled PHP (July 2nd). While to them it might appear that it's an application error, it's very likely that they compiled PHP against an older version of the MySQL server than what is being used and that is causing significant problems due to a backwards compatibility break within MySQL (using the binary protocol). Changing their MySQL bindings in PHP will likely sort it, but the trick is getting that up to a person who can understand it and deal with it.
     
  5. Zaragan

    Zaragan Member

    Ok, solved! Ty!!

    Solucion para actualizar la version de php a la 5.5 ->
    Panel de control-Hosting-Ajustes de php- Seleccionar dominio y version- Aceptar y listo!!
     
  6. bluepaw

    bluepaw Member

    OH THANK YOU! Wow, I was pulling my hair out over this trying to figure out what was going on and if I needed to roll back to last weeks backup. Changing to 5.5 PHP and giving it about 5 min to update has resolved me issue.
     

Share This Page