1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 An exception occurred: Access denied for user

Discussion in 'Installation, Upgrade, and Import Support' started by Itworx4me, Jan 19, 2014.

  1. Itworx4me

    Itworx4me Well-Known Member

    My host had to do an emergency evacuation of my server to a new server. After they transferred the site I get this error message:

    Code:
    An exception occurred: Access denied for user 'xxxxxx'@'localhost' (using password: YES) in /home/xxxxxx/public_html/library/Zend/Db/Adapter/Mysqli.php on line 333
    
    Zend_Db_Adapter_Mysqli->_connect() in Zend/Db/Adapter/Abstract.php at line 315
    Zend_Db_Adapter_Abstract->getConnection() in XenForo/Application.php at line 553
    XenForo_Application->loadDb()
    call_user_func_array() in XenForo/Application.php at line 780
    XenForo_Application->lazyLoad() in XenForo/Application.php at line 810
    XenForo_Application::get() in XenForo/Application.php at line 1098
    XenForo_Application::getDb() in XenForo/Error.php at line 47
    XenForo_Error::unexpectedException() in XenForo/Application.php at line 295
    XenForo_Application::handleException()
    I have checked all the passwords and they are correct. Just don't know what to look for next.

    Any help would be appreciated....

    Thanks,
    Itworx4me
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Check that the details in library/config.php match the database details.
     
  3. Itworx4me

    Itworx4me Well-Known Member

    I have checked them over and over... Still no luck in finding out what is causing the issue...
     
  4. Itworx4me

    Itworx4me Well-Known Member

    Is there setting in the phpinfo that didn't get configured in the new server?? To cause this issue?
     
  5. Itworx4me

    Itworx4me Well-Known Member

    I ran the xenforo requirements and passed
     
  6. Liam W

    Liam W Well-Known Member

    It's saying that the database username or password is incorrect, check them thoroughly :)

    Is the username and server correct as well?

    Liam
     
  7. Itworx4me

    Itworx4me Well-Known Member

    Ended up being a bad mysql user name. Something went screwing in the transfer. Deleting the user and creating a new one fixed the problem. ;)
     
  8. doublespaces

    doublespaces Member

    Using DirectAdmin, since it isn't clear, while importing a database, you need to use the MySQL username, not your current, DA Session username.
     

Share This Page