1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Ambiguous date format settings on specific dates

Discussion in 'Resolved Bug Reports' started by tyteen4a03, Jan 1, 2015.

  1. tyteen4a03

    tyteen4a03 Well-Known Member

    I'm trying to create a new language and I discovered that XenForo uses today's date as an example string, which causes confusion if you're editing this setting on the first of January (or second of February, etc) as you can't be sure which order the last two option represents.

    To fix this problem, use an arbitrary date.

    Screen Shot 2015-01-01 at 14.37.22.png
     
  2. Amaury

    Amaury Well-Known Member

    It's not that hard if you just remember that the last one is D/M/YY.
     
  3. tyteen4a03

    tyteen4a03 Well-Known Member

    I didn't know. You can't expect first-timers to know the difference.
     
    Xon likes this.
  4. Optic

    Optic Well-Known Member

    It would seem that the last option is actually MM/DD/YY, which caught me out:
    xenforo-create-language-date.png
     
  5. Amaury

    Amaury Well-Known Member

    Ah, okay. But yeah, remember that the last one is MM/DD/YY, then, and you're set. :)
     
  6. Mike

    Mike XenForo Developer Staff Member

    This is fixed now.
     
    tyteen4a03 likes this.
  7. Amaury

    Amaury Well-Known Member

    Out of curiosity, what was the fix? Using an arbitrary date instead of the current one?
     
  8. Mike

    Mike XenForo Developer Staff Member

    Yes.
     
    soloarquitectura and Amaury like this.

Share This Page