1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Allowed memory size Errors

Discussion in 'Enhanced Search Support' started by Marcus, Nov 12, 2013.

  1. Marcus

    Marcus Well-Known Member

    I get for some keyword searches (regular characters like: abcd) this error:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 8208 bytes) in /home/nginx/domains/domain.com/public/library/XenForo/Permission.php on line 80

    When disabling elasticsearch and rebuilding the regular search index, the search works with these keywords.

    I have latest elasticsearch and java installed.
  2. Mike

    Mike XenForo Developer Staff Member

    I'd guess you're quite close to the memory limit with the regular search as well, though there are different approaches at play here as well.

    Have you increased the maximum number of search results? Increasing that will use more memory as larger result sets are checked. You could try decreasing it.

    Otherwise, you may need to set a higher memory limit in config.php.
    Marcus likes this.
  3. Marcus

    Marcus Well-Known Member

    Great help!

    That solved my problem:
    config.php: ini_set("memory_limit","256M");
  4. RoldanLT

    RoldanLT Well-Known Member

    Should be: ini_set('memory_limit', '256M'); ?
    Vilandra and Marcus like this.
  5. Marcus

    Marcus Well-Known Member

    You can use " or '
    RoldanLT likes this.

Share This Page