1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

All forum links are broken..

Discussion in 'Troubleshooting and Problems' started by Laurentius, Dec 16, 2012.

  1. Laurentius

    Laurentius Active Member

    It looks like this problem happend the 13th, I am hosted on Hostgator.. I have been away so I noticed it now, please can someone help me fix this. www.onlydesigned.com/forum It seems to be some problems with the friendly links... If I unclick the friendly link option in the admin panel I can see the boards again, but as soon as I enables it shows page not found...
  2. Dan

    Dan Well-Known Member

    Are you sure your .htaccess file is present?
    Jake Bunce likes this.
  3. Laurentius

    Laurentius Active Member

    Yes this is whats in it:

    #Mod_security can interfere with uploading of content such as attachments. If you
    #cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #SecFilterEngine Off
    #SecFilterScanPOST Off

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default

    <IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{HTTP_HOST} !^www\.onlydesigned\.com$
    RewriteRule ^(.*)$ http://www.onlydesigned.com/forum/$1 [R=301,L]

    #If you are having problems with the rewrite rules, remove the "#" from the
    #line that begins "RewriteBase" below. You will also have to change the path
    #of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    I have talked to hostgator and they said I would be better of asking the Xenforo Community, so that wasnt much help...
  4. Dan

    Dan Well-Known Member

    And that is in the forum folder, not root? I am sure you thought of this but have you changed anything like directories? Updated PHP?
    Jake Bunce likes this.
  5. Laurentius

    Laurentius Active Member

    Yes its in /forum. It worked perfectly until recently, I have been away for 3 days and came back today and saw it now I am the only person with access to the admin and I havent touched anything.
  6. Laurentius

    Laurentius Active Member

    I have unenabled the friendly links for now, and everything works perfectly, but I want it activated...
  7. Dan

    Dan Well-Known Member

    If it isn't hostgator's issue, the only thing I could see that you could try is to change #RewriteBase /xenforo to RewriteBase /forum

    Note remove "#" and change directory
    Jake Bunce and Laurentius like this.
  8. Laurentius

    Laurentius Active Member

    It works now thank you very much! :)
    Dan likes this.
  9. Will Woods

    Will Woods New Member

    I did this and still not working! Any ideas? AllowOverride and mod_rewrite are both active on my server.
  10. SchmitzIT

    SchmitzIT Well-Known Member

    Did you rename htaccess.txt to .htaccess?
    Jake Bunce likes this.
  11. Will Woods

    Will Woods New Member

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@coachscoop.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.

    Apache Server at www.coachscoop.com Port 80
  12. Will Woods

    Will Woods New Member

    ^ That just happened when I did
  13. Will Woods

    Will Woods New Member

    Getting this server error: RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.
  14. melbo

    melbo Well-Known Member

    I can access forum and links with no problems
  15. Will Woods

    Will Woods New Member

    Figured it out, there was some rouge code somewhere...thanks!
    Jake Bunce likes this.

Share This Page