XF 1.1 After moving to new server, error "Array to string conversion"

Andy.N

Well-known member
#1
I moved the site to a new server with PHP 5.5.1 and received this error when trying to save some settings in ACP -> Options

ErrorException: Array to string conversion - library/XenForo/Input.php:192
Stack Trace
#0 [internal function]: XenForo_Application::handlePhpError(8, 'Array to string...', '/home/nginx/dom...', 192, Array)
#1 /home/nginx/domains/quantnet.com/public/library/XenForo/Input.php(192): strval(Array)
#2 /home/nginx/domains/quantnet.com/public/library/XenForo/Input.php(179): XenForo_Input::_doClean('string', Array, Array, '')
#3 /home/nginx/domains/quantnet.com/public/library/AdvancedUpgrades/ControllerAdmin/Extend/Option.php(27): XenForo_Input->filterSingle('options', 'string')
#4 /home/nginx/domains/quantnet.com/public/library/XenForo/FrontController.php(313): AdvancedUpgrades_ControllerAdmin_Extend_Option->actionSave()
#5 /home/nginx/domains/quantnet.com/public/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /home/nginx/domains/quantnet.com/public/admin.php(13): XenForo_FrontController->run()
#7 {main}
 

Brogan

XenForo moderator
Staff member
#2
Disable all add-ons and try again.

Do you have an add-on installed called Advanced Upgrades?
I note that is listed in the stack trace.
 

Andy.N

Well-known member
#3
Disable all add-ons and try again.

Do you have an add-on installed called Advanced Upgrades?
I note that is listed in the stack trace.
Yeap, that's the one. I should have seen it if I look closer at those stacktrace.
Disable it and the error gone away.
 
Last edited:
Top