• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Advanced Attachment System (AAS)

Advanced Attachment System (AAS) [Paid] 2.3.1

No permission to buy ($35.99)

au lait

Well-known member
#1
au lait submitted a new resource:

Advanced Attachment System (AAS) - Attachment SEO, PDF-Preview, Attachment options for specific forums, QR-Code and more

DEMO
User: TestAdmin
Password: testadmin


Advanced Attachment System (AAS) has SEO, PDF-Preview, Attachment options for specific forums, QR-Code and more...

Features:
  • Allows attachment settings per node for size (kB and px) and file type instead forum wide (XenForo default)
  • Allows embed PDF previews in posts
    (this require Imagick and GhostScript on server side)
  • Open PDF...
Read more about this resource...
 

Axel B

Well-known member
#4
Uninstalled 'SEO attachment name'
Tried installing 'Advanced Attachment System'
Get an error 'You must have the imagick PECL extension installed'
Asked if Mattw could add this extension on the server
Fortunately 'GhostScript' is running on the server

Suggestion: Enable installing the addon without imagick and/or ghostscript, but disable the PDF functionality if something is missing.
 

otto

Well-known member
#5
Now I can start working on my PDF archive in gallery style. Litle bit styling work to do, but it works. :)
upload_2016-2-16_19-3-19.png
These are 10 automatic generated PDF previews with a width of 150px - as eg. :)

@Axel B
For PDF preview handle are Imagick and GhostScript required.

But...
Suggestion: Enable installing the addon without imagick and/or ghostscript, but disable the PDF functionality if something is missing.
This is a good point. (y)
 

Axel B

Well-known member
#9
I have both Imagick PHP Extension, Imagick PHP Wrapper and GhostScript installed on the server, but no Preview is created. Bug or am I missing something?
Screen Shot 2016-02-16 at 22.04.25.png
 

Sunka

Well-known member
#10
Hmmm, I have all three things installed on server but it shows me that I do not have installed GhostScript, but I have
Code:
[root@tvor-ocean ~]# rpm -q ghostscript
ghostscript-9.07-18.el7.x86_64
a - 01-45-53.png
 

otto

Well-known member
#12
I have both Imagick PHP Extension, Imagick PHP Wrapper and GhostScript installed on the server, but no Preview is created. Bug or am I missing something?
Have you embed the pdf files in a post, or only uploaded? The preview is only to see, if you embed a pdf.
 

otto

Well-known member
#14
Oh, you dont have the button "insert preview" shown. Any other addons that conflict with?

Normaly it should look like:
upload_2016-2-17_9-33-43.png

Edit:
Can you please take a look at TMS system - are all AAS template changes loaded in your style?
 

Axel B

Well-known member
#15
I have the same issue with the default style:
Screen Shot 2016-02-17 at 09.47.17.png

I have no idea what the TMS system is and how to check if all AAS template changes are loaded... I only play around with CSS :( Sorry.
I will try to force a reinstall of the addon. Perhaps that works.