1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Admin cpanel style

Discussion in 'Styling and Customization Questions' started by alkahf, Jun 11, 2013.

  1. alkahf

    alkahf Member

    Hello!
    I can't find where change font-family for admin c panel ?
    Thank you
     
  2. bousaid

    bousaid Well-Known Member

    Enable debug mode
    PHP:
    $config['debug'] = true;
    Development -> Admin Style Properties -> General -> Body
     
  3. alkahf

    alkahf Member

    Thank you
    But if you mean that I should put this string:
    PHP:
    $config['debug'] = true;
    in config.php file?
    When i did that,then all pages in forum and admin cp were blank!
     
  4. bousaid

    bousaid Well-Known Member

    yes in config.php
    :Dنعم .. ضعها في الكونفج لكي تفعل منقح البرمجة و من هناك تستطيع التعديل على ستايل الادارة كما تشاء
     
  5. alkahf

    alkahf Member

     
  6. Brogan

    Brogan XenForo Moderator Staff Member

  7. alkahf

    alkahf Member

  8. alkahf

    alkahf Member

    bousaid thank you
    But the problem with your string! :)
    Copy please your string from your reply and past it in config file, then look please will your XF working? ;)
    two days to find the reason!

    alkahf
     
  9. bousaid

    bousaid Well-Known Member

    yes imad ... works fine
    My Config in localhost :D
    and works in my site
    Maybe problem in your Host !!
     

    Attached Files:

    • co.png
      co.png
      File size:
      43 KB
      Views:
      5
  10. alkahf

    alkahf Member

    My you don't understand what i mean!!!!!
    Ok:
    now open your config.php in localhost and remove $config['debug'] = true;
    then copy/past your :
    that you wrote it there: http://xenforo.com/community/threads/admin-cpanel-style.52276/#post-559506
    then save it.
    and open your forum in browser.
    Then you will see blank page!!!!o_O
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    No, I don't see a blank page. You need to check your server logs also as it appears that there may be something wrong with the host?
    Are you running on a shared host or VPS?
     
    bousaid likes this.
  12. bousaid

    bousaid Well-Known Member

    (y)
     
  13. alkahf

    alkahf Member

    Thankyou For your help, :)
    please try this file in attachments and tell me if you see blank page or not?
    You can try with shared host or VPS or local.
     

    Attached Files:

  14. Tracy Perry

    Tracy Perry Well-Known Member

    I found two (actually probably 3) problems
    Number 1
    $config['debug']=true;

    Number 2
    ini_set('display_errors',true);

    You have extraneous characters before and after your "=" sign.
    Also, your ini_set has the same character in it (highlighted in orange).

    Number 3
    It looks like you may be using a Windows editor to do this in.... BIG NO-NO unless you are using something like Notepad ++. When I went to save your example it prompted me to save it in a Windows format (this is on a Mac).
     
    Last edited: Jun 17, 2013
    bousaid and Shelley like this.
  15. alkahf

    alkahf Member

  16. Tracy Perry

    Tracy Perry Well-Known Member

    Nope... it's your editor (or the format you saved it in). If you have the option, save it in Unix (LF).
    http://notepad-plus-plus.org/ is generally highly recommended (and the price is right - free).
    Was going to suggest sending the information for the top part of the config.php to me via conversation and I would edit it and attach it back to the conversation - but then remembered you can't attach files here to a conversation. :cautious:
     
  17. alkahf

    alkahf Member

    Thank you Tracy so much (y)
     
  18. Tracy Perry

    Tracy Perry Well-Known Member

    No problem... and please update the post if the problem is resolved.
     
    Shelley likes this.
  19. alkahf

    alkahf Member

    Yes it resolved!
    But i don't understand why it was happened only when i copy from XF's threads and past in Edit plus??
    i use Edit plus 13 years and this is first time i have this problem!
    Do you think Tracy that happen because XF writes by Unix system?


    Regards
     
  20. Tracy Perry

    Tracy Perry Well-Known Member

    May have just been a quirk. If you are saving down to a Linux system (Debian, centOS, etc) then it's important. When saving, always use an editor that can write in the Unix LF format (preferrable).
    I don't think on a Windows server it really matters that much.
     
    bousaid likes this.

Share This Page