• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed Addon Handlers

xf_phantom

Well-known member
#1
When i deactivate an addon with a search/moderation/report handler, it won't remove/deactivate the handlers, if a deactivate an addon.

This is very confusing.

to reproduce it, you'll need at least 1 addon with custom handlers

steps to reproduce with RM:
  • install resource manager
  • create a testresource with "searchhandler test"
  • report the resource
  • deactivate the addon
  • search for "searchhandler test"
expected result: item will be removed from the reported items queue (and all the other handlers) and resource won't be shown if you search for "searchhandler"

but the resource will be shown in the search result and the result link will go to a errorpage "A controller for the route path resources/ was not found."

and the same problems will happen in the reported items queue (i'm sure it will happen in the modqueue too and all the other handlers. e.g. alert)

see also http://xenforo.com/community/threads/users-awaiting-approval.53173/#post-568800
 

Mike

XenForo developer
Staff member
#3
This has been fixed - it actually changed quite a few places which unfortunately weren't using the content type cache (probably didn't exist at the time), but they are now. The content type cache will only include elements attached to add-ons that are enabled. (Note that if you add a new handler for a content type that is associated with another add-on [such as posts or threads], the content type isn't associated with your add-on so your handler won't be delayed.)