• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Addon Chat integration issue

#1
Good evening. I recently purchased addonchat for my forum. The add on installed fine with no errors, but when i attempt to sign on to chat i get an error:

Undefined index: hashFunc

XenForo_Application::handlePhpError() in AddonChat/Model/User.php at line 93
AddonChat_Model_User->initialize() in AddonChat/Model/User.php at line 61
AddonChat_Model_User->__construct() in AddonChat/ControllerPublic/Index.php at line 93
AddonChat_ControllerPublic_Index->prepareChat() in AddonChat/ControllerPublic/Index.php at line 45
AddonChat_ControllerPublic_Index->actionPopup() in XenForo/FrontController.php at line 310
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /home/wiipalsn/public_html/index.php at line 13

I posted a ticket two days ago, with no response. I was wondering if anyone have had an error similar to this or if anyone would have any idea what the heck is going on.
 

Jake Bunce

XenForo moderator
Staff member
#2
Can you post a link to that addon?

This appears to be a bug in that addon. I may be able to find a fix for you. Otherwise I suggest downloading an update for the addon or contacting the author.
 

Jake Bunce

XenForo moderator
Staff member
#4
Did you ever import to XenForo from another forum like vB, IPB, or phpBB?

This addon is hard-coded to use the "Core" auth scheme which uses hashFunc. But if you imported from another forum then it would use a different auth scheme which would explain this error. One fix would be to reset that user's password thereby generating a new auth record with the "Core" scheme. Otherwise this addon needs to be updated to check the auth scheme of the user (contact the author).